aboutsummaryrefslogtreecommitdiffstats
path: root/package/toolchain/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-11-23 20:02:29 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-11-23 20:02:29 +0000
commit24cc4007ce46bb076bfe2879f66f19f52161f098 (patch)
treebc44c7e2aea0c387867ce3601e782b02a940d79e /package/toolchain/Makefile
parentee048e8c321170b8eb9f06c65baa44d17b3455e1 (diff)
downloadmaster-187ad058-24cc4007ce46bb076bfe2879f66f19f52161f098.tar.gz
master-187ad058-24cc4007ce46bb076bfe2879f66f19f52161f098.tar.bz2
master-187ad058-24cc4007ce46bb076bfe2879f66f19f52161f098.zip
[buildroot] add preliminary support for musl
Musl is an alternative C-library, see http://www.musl-libc.org for more infos. Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34314 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/toolchain/Makefile')
-rw-r--r--package/toolchain/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/package/toolchain/Makefile b/package/toolchain/Makefile
index 265587ed5f..84fc3e6b2f 100644
--- a/package/toolchain/Makefile
+++ b/package/toolchain/Makefile
@@ -426,6 +426,16 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
$(1)/lib/
endef
+ define Package/musl/install
+ $(INSTALL_DIR) $(1)/lib
+ $(CP) \
+ $(TOOLCHAIN_DIR)/lib/ld-musl-*.so* \
+ $(1)/lib/
+ $(CP) \
+ $(TOOLCHAIN_DIR)/lib/libc.so* \
+ $(1)/lib/
+ endef
+
define Package/libc/install
$(call Package/$(LIBC)/install,$1)
endef