aboutsummaryrefslogtreecommitdiffstats
path: root/package/system
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2015-11-10 00:16:37 +0000
committerLuka Perkov <luka@openwrt.org>2015-11-10 00:16:37 +0000
commit9a28a84b8154e48243ddd1663c297d5806521d19 (patch)
tree6e34f5863b3d0676b7d44a848b5b7bf5030c2168 /package/system
parent313cacaf9a572d3e75f2f45d5d1dcdd271e6db9f (diff)
downloadmaster-187ad058-9a28a84b8154e48243ddd1663c297d5806521d19.tar.gz
master-187ad058-9a28a84b8154e48243ddd1663c297d5806521d19.tar.bz2
master-187ad058-9a28a84b8154e48243ddd1663c297d5806521d19.zip
kirkwood: support Linksys boot counter on EA[34]500
This is done with existing code from the WRT1900AC port. It makes sure the "auto_recovery" bootloader option is set, and resets the s_env boot counter after a successful boot. This gives users without a serial console connection some measure of safety. Signed-off-by: Claudio Leite <leitec@staticky.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47433 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/system')
-rw-r--r--package/system/mtd/src/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/system/mtd/src/Makefile b/package/system/mtd/src/Makefile
index 40a165e4e6..1e02ce94ee 100644
--- a/package/system/mtd/src/Makefile
+++ b/package/system/mtd/src/Makefile
@@ -11,6 +11,7 @@ obj.bcm53xx = $(obj.brcm)
obj.brcm63xx = imagetag.o
obj.ramips = $(obj.seama)
obj.mvebu = linksys_bootcount.o
+obj.kirkwood = linksys_bootcount.o
ifdef FIS_SUPPORT
obj += fis.o