aboutsummaryrefslogtreecommitdiffstats
path: root/package/system
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-10-16 10:30:16 +0000
committerJo-Philipp Wich <jow@openwrt.org>2014-10-16 10:30:16 +0000
commit41f42651018420470e57ee4483db06ccad8ec0c6 (patch)
treedaefccf3d5b079cdedf80a9a4352349b64115167 /package/system
parentb3c29f9f2368461851e80e430143ec48212db97a (diff)
downloadmaster-187ad058-41f42651018420470e57ee4483db06ccad8ec0c6.tar.gz
master-187ad058-41f42651018420470e57ee4483db06ccad8ec0c6.tar.bz2
master-187ad058-41f42651018420470e57ee4483db06ccad8ec0c6.zip
build: improve feed handling for opkg.conf
- Consider not installed feeds as well - Add option to decide whether to comment disabled feeds Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42931 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/system')
-rw-r--r--package/system/opkg/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/system/opkg/Makefile b/package/system/opkg/Makefile
index 8a63fb4352..6dd3f31818 100644
--- a/package/system/opkg/Makefile
+++ b/package/system/opkg/Makefile
@@ -113,7 +113,7 @@ define Package/opkg/Default/install
done
ifneq ($(CONFIG_PER_FEED_REPO_ADD_DISABLED),)
for d in $(FEEDS_DISABLED); do \
- echo "# src/gz %n_$$$$d %U/$$$$d" >> $(1)/etc/opkg.conf; \
+ echo "$(if $(CONFIG_PER_FEED_REPO_ADD_COMMENTED),# )src/gz %n_$$$$d %U/$$$$d" >> $(1)/etc/opkg.conf; \
done
endif
endif