aboutsummaryrefslogtreecommitdiffstats
path: root/package/switch/src/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-05-31 16:01:46 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-05-31 16:01:46 +0000
commit2ec7843bec8ad7173298213a8cc0a33712949c44 (patch)
tree460661226ea23e959d2cfbac10dff5c1b12b2fd7 /package/switch/src/Makefile
parent7fb25c05a58b96c1f413c1004932bd27294d0bb9 (diff)
downloadmaster-187ad058-2ec7843bec8ad7173298213a8cc0a33712949c44.tar.gz
master-187ad058-2ec7843bec8ad7173298213a8cc0a33712949c44.tar.bz2
master-187ad058-2ec7843bec8ad7173298213a8cc0a33712949c44.zip
move target/linux/package/switch to package/, fix a bug in the ipkg dependency handling
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@3864 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/switch/src/Makefile')
-rw-r--r--package/switch/src/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/package/switch/src/Makefile b/package/switch/src/Makefile
new file mode 100644
index 0000000000..4c5f911ea2
--- /dev/null
+++ b/package/switch/src/Makefile
@@ -0,0 +1,19 @@
+# $Id$
+#
+# Makefile for switch driver
+#
+# Copyright (C) 2005 Felix Fietkau <nbd@openwrt.org>
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version
+# 2 of the License, or (at your option) any later version.
+#
+
+obj-m := switch-core.o switch-adm.o switch-robo.o
+
+ifeq ($(MAKING_MODULES),1)
+export-objs := switch-core.o
+
+-include $(TOPDIR)/Rules.make
+endif