aboutsummaryrefslogtreecommitdiffstats
path: root/package/switch/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-07-30 03:09:09 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-07-30 03:09:09 +0000
commitd3a6fe9915875cb78ca3d22f8330a0380dcd58a0 (patch)
tree3a7ec356cf8ec9ada9d0ddbf6ccbd1cbb9aae869 /package/switch/Makefile
parentd5aeb2645530079ac89ed72e2eee91fbcbc38e84 (diff)
downloadmaster-187ad058-d3a6fe9915875cb78ca3d22f8330a0380dcd58a0.tar.gz
master-187ad058-d3a6fe9915875cb78ca3d22f8330a0380dcd58a0.tar.bz2
master-187ad058-d3a6fe9915875cb78ca3d22f8330a0380dcd58a0.zip
rewrite of the network scripts and configuration
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4323 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/switch/Makefile')
-rw-r--r--package/switch/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/switch/Makefile b/package/switch/Makefile
index 5513394fd6..860e530c4c 100644
--- a/package/switch/Makefile
+++ b/package/switch/Makefile
@@ -42,6 +42,10 @@ define Build/Compile
endef
define Package/kmod-switch/install
+ install -m0755 -d $(1)/lib/network/
+ install -m0755 ./files/switch.sh $(1)/lib/network/
+ install -m0755 -d $(1)/etc/modules.d/
+ printf 'switch-core\nswitch-robo\nswitch-adm\n' > $(1)/etc/modules.d/20-switch
install -m0755 -d $(1)/lib/modules/$(LINUX_VERSION)
$(CP) $(PKG_BUILD_DIR)/*.$(LINUX_KMOD_SUFFIX) \
$(1)/lib/modules/$(LINUX_VERSION)