aboutsummaryrefslogtreecommitdiffstats
path: root/package/rules.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-06-27 10:02:35 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-06-27 10:02:35 +0000
commitd927e4d566e9c2adb7ae137d041ff9d4d9b8fa2f (patch)
tree919b5a242773a0d4aa30db134fe7581775781c8e /package/rules.mk
parent1d19b2b457608cd3a98a804b88e6cce53b4c609a (diff)
downloadmaster-187ad058-d927e4d566e9c2adb7ae137d041ff9d4d9b8fa2f.tar.gz
master-187ad058-d927e4d566e9c2adb7ae137d041ff9d4d9b8fa2f.tar.bz2
master-187ad058-d927e4d566e9c2adb7ae137d041ff9d4d9b8fa2f.zip
add depends to the default package template
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1291 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/rules.mk')
-rw-r--r--package/rules.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/rules.mk b/package/rules.mk
index 6f2573e9c7..a95c4e421b 100644
--- a/package/rules.mk
+++ b/package/rules.mk
@@ -13,8 +13,11 @@ ifeq ($(BR2_PACKAGE_$(1)),y)
install: $$(INFO_$(1))
endif
+IDEPEND_$(1):=$$(strip $(5))
+
$$(IDIR_$(1))/CONTROL/control: $(PKG_BUILD_DIR)/.prepared
$(SCRIPT_DIR)/make-ipkg-dir.sh $$(IDIR_$(1)) ./ipkg/$(2).control $(3) $(4)
+ if [ "$$(IDEPEND_$(1))" != "" ]; then echo "Depends: $$(IDEPEND_$(1))" >> $$(IDIR_$(1))/CONTROL/control; fi
for file in conffiles preinst postinst prerm postrm; do \
[ -f ./ipkg/$(2).$$$$file ] && cp ./ipkg/$(2).$$$$file $$(IDIR_$(1))/CONTROL/$$$$file || true; \
done