aboutsummaryrefslogtreecommitdiffstats
path: root/package/ppp/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-07-30 03:09:09 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-07-30 03:09:09 +0000
commitd3a6fe9915875cb78ca3d22f8330a0380dcd58a0 (patch)
tree3a7ec356cf8ec9ada9d0ddbf6ccbd1cbb9aae869 /package/ppp/Makefile
parentd5aeb2645530079ac89ed72e2eee91fbcbc38e84 (diff)
downloadmaster-187ad058-d3a6fe9915875cb78ca3d22f8330a0380dcd58a0.tar.gz
master-187ad058-d3a6fe9915875cb78ca3d22f8330a0380dcd58a0.tar.bz2
master-187ad058-d3a6fe9915875cb78ca3d22f8330a0380dcd58a0.zip
rewrite of the network scripts and configuration
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4323 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/ppp/Makefile')
-rw-r--r--package/ppp/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/package/ppp/Makefile b/package/ppp/Makefile
index 85d52d0542..e49b610c36 100644
--- a/package/ppp/Makefile
+++ b/package/ppp/Makefile
@@ -95,6 +95,8 @@ define Build/Compile
endef
define Package/ppp/install
+ install -d -m0755 $(1)/lib/network
+ install -m0755 ./files/ppp.sh $(1)/lib/network/
install -d -m0755 $(1)/etc/ppp
install -m0600 ./files/etc/ppp/chap-secrets $(1)/etc/ppp/
install -m0644 ./files/etc/ppp/filter $(1)/etc/ppp/
@@ -110,19 +112,19 @@ define Package/ppp/install
endef
define Package/ppp-mod-pppoa/install
+ install -d -m0755 $(1)/lib/network
+ install -m0755 ./files/pppoa.sh $(1)/lib/network/
install -d -m0755 $(1)/usr/lib/pppd/$(PKG_VERSION)
install -m0755 $(PKG_INSTALL_DIR)/usr/lib/pppd/$(PKG_VERSION)/pppoatm.so \
$(1)/usr/lib/pppd/$(PKG_VERSION)/
- install -d -m0755 $(1)/sbin
- install -m0755 ./files/ifup.pppoa $(1)/sbin/
endef
define Package/ppp-mod-pppoe/install
+ install -d -m0755 $(1)/lib/network
+ install -m0755 ./files/pppoe.sh $(1)/lib/network/
install -d -m0755 $(1)/usr/lib/pppd/$(PKG_VERSION)
install -m0755 $(PKG_INSTALL_DIR)/usr/lib/pppd/$(PKG_VERSION)/rp-pppoe.so \
$(1)/usr/lib/pppd/$(PKG_VERSION)/
- install -d -m0755 $(1)/sbin
- install -m0755 ./files/ifup.pppoe $(1)/sbin/
endef
define Package/ppp-mod-radius/install