aboutsummaryrefslogtreecommitdiffstats
path: root/package/ppp/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-07-03 18:02:34 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-07-03 18:02:34 +0000
commit4de322b01a2525c4242235ea506646c1c67d0e02 (patch)
tree8631b249c172b63721d481686c8328c73ae075a0 /package/ppp/Makefile
parentb4245ce00199f3c98231473e06ed40c8b790df5e (diff)
downloadmaster-187ad058-4de322b01a2525c4242235ea506646c1c67d0e02.tar.gz
master-187ad058-4de322b01a2525c4242235ea506646c1c67d0e02.tar.bz2
master-187ad058-4de322b01a2525c4242235ea506646c1c67d0e02.zip
remove pppoe init script, add ifup.pppoe for that
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1325 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/ppp/Makefile')
-rw-r--r--package/ppp/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/ppp/Makefile b/package/ppp/Makefile
index e1c3907cee..1b95a76c72 100644
--- a/package/ppp/Makefile
+++ b/package/ppp/Makefile
@@ -70,6 +70,7 @@ $(PKG_BUILD_DIR)/.built:
$(MAKE) -C $(PKG_BUILD_DIR) \
CC=$(TARGET_CC) \
COPTS="$(TARGET_CFLAGS)" \
+ HAVE_INET6="1" \
DESTDIR="$(PKG_INSTALL_DIR)/usr" \
all install
touch $@
@@ -88,8 +89,8 @@ $(IPKG_PPP):
$(IPKG_BUILD) $(IDIR_PPP) $(PACKAGE_DIR)
$(IDIR_PPP_MOD_PPPOE)/etc/init.d/S50pppoe:
- install -d -m0755 $(IDIR_PPP_MOD_PPPOE)/etc/init.d
- install -m0755 ./files/pppoe.init $(IDIR_PPP_MOD_PPPOE)/etc/init.d/S50pppoe
+ install -d -m0755 $(IDIR_PPP_MOD_PPPOE)/sbin
+ install -m0755 ./files/ifup.pppoe $(IDIR_PPP_MOD_PPPOE)/sbin/
$(IPKG_PPP_MOD_PPPOE): $(IDIR_PPP_MOD_PPPOE)/etc/init.d/S50pppoe