aboutsummaryrefslogtreecommitdiffstats
path: root/package/opkg/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-10-20 08:21:10 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-10-20 08:21:10 +0000
commit0ee55d9f550693ab256403115b03dc521a605cd0 (patch)
treeef8ee0bd020017d3be78d8ceb88685ccc4c56cce /package/opkg/Makefile
parentfd2da7768efe5b06c8f2bea9c3d740fac648668c (diff)
downloadmaster-187ad058-0ee55d9f550693ab256403115b03dc521a605cd0.tar.gz
master-187ad058-0ee55d9f550693ab256403115b03dc521a605cd0.tar.bz2
master-187ad058-0ee55d9f550693ab256403115b03dc521a605cd0.zip
opkg: get rid of libopkg, saves >10k compressed, >40k uncompressed
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18091 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/opkg/Makefile')
-rw-r--r--package/opkg/Makefile5
1 files changed, 1 insertions, 4 deletions
diff --git a/package/opkg/Makefile b/package/opkg/Makefile
index d72cc0ce41..68bc8efe10 100644
--- a/package/opkg/Makefile
+++ b/package/opkg/Makefile
@@ -41,9 +41,8 @@ define Package/opkg/conffiles
/etc/opkg.conf
endef
-TARGET_CFLAGS += $(FPIC) $(if $(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4),-Wno-array-bounds)
+TARGET_CFLAGS += $(if $(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4),-Wno-array-bounds)
EXTRA_CFLAGS += $(TARGET_CPPFLAGS)
-EXTRA_LDFLAGS += $(TARGET_LDFLAGS) -Wl,-rpath-link,$(STAGING_DIR)/usr/lib
CONFIGURE_ARGS += \
--disable-curl \
@@ -72,8 +71,6 @@ define Package/opkg/install
$(INSTALL_DATA) ./files/opkg.conf $(1)/etc/
$(SED) 's,$$$$S,$(PKGARCH),g' $(1)/etc/opkg.conf
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/opkg-cl $(1)/bin/opkg
- $(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libopkg.so.* $(1)/usr/lib/
endef
define Build/InstallDev