aboutsummaryrefslogtreecommitdiffstats
path: root/package/openswan
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2008-08-20 22:00:41 +0000
committerNicolas Thill <nico@openwrt.org>2008-08-20 22:00:41 +0000
commitbd08c5928d1f1549fa56934d26f8349a7f91d119 (patch)
tree149edda4b47c81266b596236bcae903222cf1824 /package/openswan
parent080dc036df44ade669021062ce0eb3745a3adb80 (diff)
downloadmaster-187ad058-bd08c5928d1f1549fa56934d26f8349a7f91d119.tar.gz
master-187ad058-bd08c5928d1f1549fa56934d26f8349a7f91d119.tar.bz2
master-187ad058-bd08c5928d1f1549fa56934d26f8349a7f91d119.zip
move more extra packages from ./trunk to ./packages
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12359 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/openswan')
-rw-r--r--package/openswan/Makefile96
-rwxr-xr-xpackage/openswan/files/ipsec.init158
-rw-r--r--package/openswan/patches/110-scripts.patch33
-rw-r--r--package/openswan/patches/120-use_dev_urandom.patch39
4 files changed, 0 insertions, 326 deletions
diff --git a/package/openswan/Makefile b/package/openswan/Makefile
deleted file mode 100644
index 6b6821dcfc..0000000000
--- a/package/openswan/Makefile
+++ /dev/null
@@ -1,96 +0,0 @@
-#
-# Copyright (C) 2006-2008 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-# $Id$
-
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/kernel.mk
-
-PKG_NAME:=openswan
-PKG_VERSION:=2.4.10
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.openswan.org/download
-PKG_MD5SUM:=2b36785342c74d524d8d86bde89a445f
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/openswan/Default
- TITLE:=Openswan
- URL:=http://www.openswan.org/
- DEPENDS:=@BROKEN
-endef
-
-define Package/openswan/Default/description
- Openswan is an IPsec implementation for Linux.
-endef
-
-define Package/openswan
-$(call Package/openswan/Default)
- SECTION:=net
- CATEGORY:=Network
- DEPENDS+= +kmod-openswan +libgmp +ip
- TITLE+= (daemon)
- URL:=http://www.openswan.org/
-endef
-
-define Package/openswan/description
-$(call Package/openswan/Default/description)
- This package contains the Openswan user-land daemon.
-endef
-
-define KernelPackage/openswan
-$(call Package/openswan/Default)
- SUBMENU:=Network Support
- TITLE+= (kernel module)
- FILES:=$(PKG_BUILD_DIR)/modobj*/ipsec.$(LINUX_KMOD_SUFFIX)
-endef
-
-define KernelPackage/openswan/description
-$(call Package/openswan/Default/description)
- This package contains the Openswan kernel module.
-endef
-
-TARGET_CPPFLAGS = \
- -I$(STAGING_DIR)/usr/include \
- -I$(LINUX_DIR)/include
-
-TARGET_LDFLAGS = \
- -L$(STAGING_DIR)/usr/lib
-
-OPENSWAN_MAKE := $(MAKE) -C $(PKG_BUILD_DIR) \
- $(TARGET_CONFIGURE_OPTS) \
- LINUX_RELEASE="$(LINUX_RELEASE)" \
- KERNELSRC="$(LINUX_DIR)" \
- ARCH="$(LINUX_KARCH)" \
- CROSS_COMPILE="$(TARGET_CROSS)" \
- USERCOMPILE="$(TARGET_CFLAGS) -I$(PKG_BUILD_DIR)/linux/include $(TARGET_CPPFLAGS) $(TARGET_LDFLAGS)" \
- IPSECDIR="/usr/lib/ipsec" \
- INC_USRLOCAL="/usr" \
- INC_RCDEFAULT="/etc/init.d" \
- MODPROBE="/sbin/insmod" \
- LDFLAGS="$(TARGET_LDFLAGS)" \
- DESTDIR="$(PKG_INSTALL_DIR)"
-
-define Build/Compile
- $(OPENSWAN_MAKE) \
- programs module install
-endef
-
-define Package/openswan/install
- $(CP) $(PKG_INSTALL_DIR)/* $(1)
- $(INSTALL_DIR) $(1)/etc/init.d
- $(CP) ./files/ipsec.init $(1)/etc/init.d/ipsec
- rm -rf $(1)/usr/share
- rm -rf $(1)/usr/man
- rm -rf $(1)/var
- rm -rf $(1)/etc/rc.d
- find $(1) -name \*.old | xargs rm -rf
-endef
-
-$(eval $(call BuildPackage,openswan))
-$(eval $(call KernelPackage,openswan))
diff --git a/package/openswan/files/ipsec.init b/package/openswan/files/ipsec.init
deleted file mode 100755
index 33c416351d..0000000000
--- a/package/openswan/files/ipsec.init
+++ /dev/null
@@ -1,158 +0,0 @@
-#!/bin/sh /etc/rc.common
-# IPsec startup and shutdown script
-# Copyright (C) 1998, 1999, 2001 Henry Spencer.
-# Copyright (C) 2002 Michael Richardson <mcr@freeswan.org>
-# Copyright (C) 2006 OpenWrt.org
-#
-# This program is free software; you can redistribute it and/or modify it
-# under the terms of the GNU General Public License as published by the
-# Free Software Foundation; either version 2 of the License, or (at your
-# option) any later version. See <http://www.fsf.org/copyleft/gpl.txt>.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
-# or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
-# for more details.
-#
-# RCSID $Id: setup.in,v 1.122.6.1 2005/07/25 19:17:03 ken Exp $
-#
-# ipsec init.d script for starting and stopping
-# the IPsec security subsystem (KLIPS and Pluto).
-#
-# This script becomes /etc/rc.d/init.d/ipsec (or possibly /etc/init.d/ipsec)
-# and is also accessible as "ipsec setup" (the preferred route for human
-# invocation).
-#
-# The startup and shutdown times are a difficult compromise (in particular,
-# it is almost impossible to reconcile them with the insanely early/late
-# times of NFS filesystem startup/shutdown). Startup is after startup of
-# syslog and pcmcia support; shutdown is just before shutdown of syslog.
-#
-# chkconfig: 2345 47 76
-# description: IPsec provides encrypted and authenticated communications; \
-# KLIPS is the kernel half of it, Pluto is the user-level management daemon.
-
-START=60
-script_init() {
- me='ipsec setup' # for messages
-
- # where the private directory and the config files are
- IPSEC_EXECDIR="${IPSEC_EXECDIR-/usr/libexec/ipsec}"
- IPSEC_LIBDIR="${IPSEC_LIBDIR-/usr/lib/ipsec}"
- IPSEC_SBINDIR="${IPSEC_SBINDIR-/usr/sbin}"
- IPSEC_CONFS="${IPSEC_CONFS-/etc}"
-
- if test " $IPSEC_DIR" = " " # if we were not called by the ipsec command
- then
- # we must establish a suitable PATH ourselves
- PATH="${IPSEC_SBINDIR}":/sbin:/usr/sbin:/usr/local/bin:/bin:/usr/bin
- export PATH
-
- IPSEC_DIR="$IPSEC_LIBDIR"
- export IPSEC_DIR IPSEC_CONFS IPSEC_LIBDIR IPSEC_EXECDIR
- fi
-
- # Check that the ipsec command is available.
- found=
- for dir in `echo $PATH | tr ':' ' '`
- do
- if test -f $dir/ipsec -a -x $dir/ipsec
- then
- found=yes
- break # NOTE BREAK OUT
- fi
- done
- if ! test "$found"
- then
- echo "cannot find ipsec command -- \`$1' aborted" |
- logger -s -p daemon.error -t ipsec_setup
- exit 1
- fi
-
- # Pick up IPsec configuration (until we have done this, successfully, we
- # do not know where errors should go, hence the explicit "daemon.error"s.)
- # Note the "--export", which exports the variables created.
- eval `ipsec _confread $config --optional --varprefix IPSEC --export --type config setup`
-
- if test " $IPSEC_confreadstatus" != " "
- then
- case $1 in
- stop|--stop|_autostop)
- echo "$IPSEC_confreadstatus -- \`$1' may not work" |
- logger -s -p daemon.error -t ipsec_setup;;
-
- *) echo "$IPSEC_confreadstatus -- \`$1' aborted" |
- logger -s -p daemon.error -t ipsec_setup;
- exit 1;;
- esac
- fi
-
- IPSEC_confreadsection=${IPSEC_confreadsection:-setup}
- export IPSEC_confreadsection
-
- IPSECsyslog=${IPSECsyslog-daemon.error}
- export IPSECsyslog
-
- # misc setup
- umask 022
-
- mkdir -p /var/run/pluto
-}
-
-script_command() {
- if [ "${USER}" != "root" ]
- then
- echo "permission denied (must be superuser)" |
- logger -s -p $IPSECsyslog -t ipsec_setup 2>&1
- exit 1
- fi
- # make sure all required directories exist
- if [ ! -d /var/run/pluto ]
- then
- mkdir -p /var/run/pluto
- fi
- if [ ! -d /var/lock/subsys ]
- then
- mkdir -p /var/lock/subsys
- fi
- tmp=/var/run/pluto/ipsec_setup.st
- outtmp=/var/run/pluto/ipsec_setup.out
- (
- ipsec _realsetup $1
- echo "$?" >$tmp
- ) > ${outtmp} 2>&1
- st=$?
- if test -f $tmp
- then
- st=`cat $tmp`
- rm -f $tmp
- fi
- if [ -f ${outtmp} ]; then
- cat ${outtmp} | logger -s -p $IPSECsyslog -t ipsec_setup 2>&1
- rm -f ${outtmp}
- fi
-}
-
-
-start() {
- script_init start "$@"
- script_command start "$@"
-}
-
-stop() {
- script_init stop "$@"
- script_command stop "$@"
-}
-
-restart() {
- script_init stop "$@"
- script_command stop "$@"
- script_command start "$@"
-}
-
-status() {
- script_init status "$@"
- ipsec _realsetup status
-}
-EXTRA_COMMANDS=status
-EXTRA_HELP=" status Show the status of the service"
diff --git a/package/openswan/patches/110-scripts.patch b/package/openswan/patches/110-scripts.patch
deleted file mode 100644
index d605ceaba4..0000000000
--- a/package/openswan/patches/110-scripts.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-diff -urN openswan.old/programs/loggerfix openswan.dev/programs/loggerfix
---- openswan.old/programs/loggerfix 1970-01-01 01:00:00.000000000 +0100
-+++ openswan.dev/programs/loggerfix 2006-10-08 20:41:08.000000000 +0200
-@@ -0,0 +1,5 @@
-+#!/bin/sh
-+# use filename instead of /dev/null to log, but dont log to flash or ram
-+# pref. log to nfs mount
-+echo "$*" >> /dev/null
-+exit 0
-diff -urN openswan.old/programs/_plutorun/_plutorun.in openswan.dev/programs/_plutorun/_plutorun.in
---- openswan.old/programs/_plutorun/_plutorun.in 2006-10-08 20:43:21.000000000 +0200
-+++ openswan.dev/programs/_plutorun/_plutorun.in 2006-10-08 20:41:08.000000000 +0200
-@@ -147,7 +147,7 @@
- exit 1
- fi
- else
-- if test ! -w "`dirname $stderrlog`"
-+ if test ! -w "`echo $stderrlog | sed -r 's/(^.*\/)(.*$)/\1/'`"
- then
- echo Cannot write to directory to create \"$stderrlog\".
- exit 1
-diff -urN openswan.old/programs/_realsetup/_realsetup.in openswan.dev/programs/_realsetup/_realsetup.in
---- openswan.old/programs/_realsetup/_realsetup.in 2006-10-08 20:43:21.000000000 +0200
-+++ openswan.dev/programs/_realsetup/_realsetup.in 2006-10-08 20:41:08.000000000 +0200
-@@ -232,7 +232,7 @@
-
- # misc pre-Pluto setup
-
-- perform test -d `dirname $subsyslock` "&&" touch $subsyslock
-+ perform test -d `echo $subsyslock | sed -r 's/(^.*\/)(.*$)/\1/'` "&&" touch $subsyslock "&&" rm -f $subsyslock
-
- if test " $IPSECforwardcontrol" = " yes"
- then
diff --git a/package/openswan/patches/120-use_dev_urandom.patch b/package/openswan/patches/120-use_dev_urandom.patch
deleted file mode 100644
index 6bbcbf1647..0000000000
--- a/package/openswan/patches/120-use_dev_urandom.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-Index: openswan-2.4.8/programs/ranbits/ranbits.c
-===================================================================
---- openswan-2.4.8.orig/programs/ranbits/ranbits.c 2007-06-04 13:22:49.835279168 +0200
-+++ openswan-2.4.8/programs/ranbits/ranbits.c 2007-06-04 13:22:51.648003592 +0200
-@@ -29,7 +29,7 @@
- #include <openswan.h>
-
- #ifndef DEVICE
--#define DEVICE "/dev/random"
-+#define DEVICE "/dev/urandom"
- #endif
- #ifndef QDEVICE
- #define QDEVICE "/dev/urandom"
-Index: openswan-2.4.8/programs/rsasigkey/rsasigkey.c
-===================================================================
---- openswan-2.4.8.orig/programs/rsasigkey/rsasigkey.c 2007-06-04 13:22:49.842278104 +0200
-+++ openswan-2.4.8/programs/rsasigkey/rsasigkey.c 2007-06-04 13:22:51.649003440 +0200
-@@ -31,7 +31,7 @@
- #include <gmp.h>
-
- #ifndef DEVICE
--#define DEVICE "/dev/random"
-+#define DEVICE "/dev/urandom"
- #endif
- #ifndef MAXBITS
- #define MAXBITS 20000
-Index: openswan-2.4.8/programs/starter/files.h
-===================================================================
---- openswan-2.4.8.orig/programs/starter/files.h 2007-06-04 13:22:49.850276888 +0200
-+++ openswan-2.4.8/programs/starter/files.h 2007-06-04 13:22:51.649003440 +0200
-@@ -36,7 +36,7 @@
-
- #define MY_PID_FILE "/var/run/pluto/ipsec-starter.pid"
-
--#define DEV_RANDOM "/dev/random"
-+#define DEV_RANDOM "/dev/urandom"
- #define DEV_URANDOM "/dev/urandom"
-
- #define PROC_IPSECVERSION "/proc/net/ipsec_version"