aboutsummaryrefslogtreecommitdiffstats
path: root/package/openssl
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-07-12 15:42:00 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-07-12 15:42:00 +0000
commit6160fa6c8bf2c24790915963c0016428cc1fd805 (patch)
tree62a18b0e992c3e874f29e0275d72a169eb7d63a7 /package/openssl
parent04edd2b07e6b30866031d07fdfe3d0b9aae3898f (diff)
downloadmaster-187ad058-6160fa6c8bf2c24790915963c0016428cc1fd805.tar.gz
master-187ad058-6160fa6c8bf2c24790915963c0016428cc1fd805.tar.bz2
master-187ad058-6160fa6c8bf2c24790915963c0016428cc1fd805.zip
enable openssl engine support on ixp4xx
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11788 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/openssl')
-rw-r--r--package/openssl/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/openssl/Makefile b/package/openssl/Makefile
index 9fca6b1498..6eafc7ed7d 100644
--- a/package/openssl/Makefile
+++ b/package/openssl/Makefile
@@ -67,8 +67,13 @@ endef
OPENSSL_NO_CIPHERS:= no-idea no-md2 no-mdc2 no-rc2 no-rc5 no-sha0 no-smime \
no-rmd160 no-aes192 no-ripemd no-camellia no-ans1 no-krb5
+ifeq ($(BOARD),ixp4xx)
+OPENSSL_OPTIONS:= shared no-ec no-err no-fips no-hw no-threads zlib-dynamic \
+ no-sse2 no-perlasm
+else
OPENSSL_OPTIONS:= shared no-ec no-err no-fips no-hw no-threads zlib-dynamic \
no-engines no-sse2 no-perlasm
+endif
define Build/Configure