aboutsummaryrefslogtreecommitdiffstats
path: root/package/openssl/patches/remove_fips.patch
diff options
context:
space:
mode:
authorMike Baker <mbm@openwrt.org>2005-03-06 03:34:52 +0000
committerMike Baker <mbm@openwrt.org>2005-03-06 03:34:52 +0000
commit3d904bb14a330fb72f60d4b78a40435389398655 (patch)
tree4c6922d42353c39b46dcd7cd09982fbe9c1f9765 /package/openssl/patches/remove_fips.patch
parentb92a98900c8308542da9f758cd656880081f1196 (diff)
downloadmaster-187ad058-3d904bb14a330fb72f60d4b78a40435389398655.tar.gz
master-187ad058-3d904bb14a330fb72f60d4b78a40435389398655.tar.bz2
master-187ad058-3d904bb14a330fb72f60d4b78a40435389398655.zip
nbd's makefile/menuconfig rewrite
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@307 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/openssl/patches/remove_fips.patch')
-rw-r--r--package/openssl/patches/remove_fips.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/package/openssl/patches/remove_fips.patch b/package/openssl/patches/remove_fips.patch
new file mode 100644
index 0000000000..6c0c6133bc
--- /dev/null
+++ b/package/openssl/patches/remove_fips.patch
@@ -0,0 +1,35 @@
+diff -urN openssl-0.9.7e.old/Makefile.org openssl-0.9.7e/Makefile.org
+--- openssl-0.9.7e.old/Makefile.org 2004-09-28 22:52:14.000000000 +0200
++++ openssl-0.9.7e/Makefile.org 2005-03-03 15:55:11.000000000 +0100
+@@ -175,8 +175,8 @@
+ # we might set SHLIB_MARK to '$(SHARED_LIBS)'.
+ SHLIB_MARK=
+
+-DIRS= crypto fips ssl $(SHLIB_MARK) sigs apps test tools
+-SHLIBDIRS= fips crypto ssl
++DIRS= crypto ssl $(SHLIB_MARK) sigs apps test tools
++SHLIBDIRS= crypto ssl
+
+ # dirs in crypto to build
+ SDIRS= objects \
+@@ -229,7 +229,6 @@
+ libcrypto.a.sha1: libcrypto.a
+ if egrep 'define OPENSSL_FIPS' $(TOP)/include/openssl/opensslconf.h > /dev/null; then \
+ $(RANLIB) libcrypto.a; \
+- fips/sha1/fips_standalone_sha1 libcrypto.a > libcrypto.a.sha1; \
+ fi
+
+ sub_all:
+--- openssl-0.9.7e/crypto/rand/rand_lib.c 2004-07-30 16:38:00.000000000 +0200
++++ openssl-0.9.7e.patched/crypto/rand/rand_lib.c 2005-02-18 15:46:22.000000000 +0100
+@@ -63,8 +63,10 @@
+ #ifndef OPENSSL_NO_ENGINE
+ #include <openssl/engine.h>
+ #endif
++#ifdef OPENSSL_FIPS
+ #include <openssl/fips.h>
+ #include <openssl/fips_rand.h>
++#endif
+
+ #ifndef OPENSSL_NO_ENGINE
+ /* non-NULL if default_RAND_meth is ENGINE-provided */