aboutsummaryrefslogtreecommitdiffstats
path: root/package/om2p-watchdog/Makefile
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2011-11-12 10:54:06 +0000
committerGabor Juhos <juhosg@openwrt.org>2011-11-12 10:54:06 +0000
commit2aa31d4bd703ae8981cadef968b471eba40e4cbc (patch)
treed84ee99cf25333954a6aa14b417fd790ea1fb753 /package/om2p-watchdog/Makefile
parent3e6d0203d322b106e71bc3dff8c4fc20e304d226 (diff)
downloadmaster-187ad058-2aa31d4bd703ae8981cadef968b471eba40e4cbc.tar.gz
master-187ad058-2aa31d4bd703ae8981cadef968b471eba40e4cbc.tar.bz2
master-187ad058-2aa31d4bd703ae8981cadef968b471eba40e4cbc.zip
package: add om2p-watchdog script
Based on a patch by: Marek Lindner <lindner_marek@yahoo.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@28972 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/om2p-watchdog/Makefile')
-rw-r--r--package/om2p-watchdog/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/package/om2p-watchdog/Makefile b/package/om2p-watchdog/Makefile
new file mode 100644
index 0000000000..965e51f6c3
--- /dev/null
+++ b/package/om2p-watchdog/Makefile
@@ -0,0 +1,46 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=om2p-watchdog
+PKG_RELEASE:=1
+PKG_VERSION:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/om2p-watchdog
+ SECTION:=base
+ CATEGORY:=Base system
+ DEPENDS:=@TARGET_ar71xx
+ TITLE:=om2p watchdog
+ URL:=http://openwrt.org/
+endef
+
+define Package/om2p-watchdog/description
+ This package contains the hw watchdog script for the OM2P device.
+endef
+
+define Build/Prepare
+endef
+
+define Build/Compile
+endef
+
+define Build/Compile
+endef
+
+define Package/om2p-watchdog/install
+ $(INSTALL_DIR) $(1)/etc/init.d/
+ $(INSTALL_DIR) $(1)/sbin/
+ $(INSTALL_BIN) ./files/om2p-watchdog.init $(1)/etc/init.d/om2p-watchdog
+ $(INSTALL_BIN) ./files/om2p-watchdog $(1)/sbin/om2p-watchdog
+endef
+
+
+$(eval $(call BuildPackage,om2p-watchdog))
+