aboutsummaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2014-02-05 14:56:37 +0000
committerSteven Barth <steven@midlink.org>2014-02-05 14:56:37 +0000
commit5e1d10bde4595f0fc07a2070fa46c2d116799c31 (patch)
treef299752d879c9fe7a17caf6517c7bee3e6ac093c /package/network
parent2d505910f1bd25d76254827da64301a1388a4430 (diff)
downloadmaster-187ad058-5e1d10bde4595f0fc07a2070fa46c2d116799c31.tar.gz
master-187ad058-5e1d10bde4595f0fc07a2070fa46c2d116799c31.tar.bz2
master-187ad058-5e1d10bde4595f0fc07a2070fa46c2d116799c31.zip
odhcp6c: Add support for userclass and vendorclass
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39478 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network')
-rw-r--r--package/network/ipv6/odhcp6c/Makefile4
-rwxr-xr-xpackage/network/ipv6/odhcp6c/files/dhcpv6.sh10
2 files changed, 10 insertions, 4 deletions
diff --git a/package/network/ipv6/odhcp6c/Makefile b/package/network/ipv6/odhcp6c/Makefile
index b7a1513da1..709746f607 100644
--- a/package/network/ipv6/odhcp6c/Makefile
+++ b/package/network/ipv6/odhcp6c/Makefile
@@ -8,14 +8,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=odhcp6c
-PKG_VERSION:=2014-01-31
+PKG_VERSION:=2014-02-05
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_URL:=git://github.com/sbyx/odhcp6c.git
PKG_SOURCE_PROTO:=git
-PKG_SOURCE_VERSION:=b4a0f3d74b04074eae21e88fbf5b8f2ddc150f86
+PKG_SOURCE_VERSION:=db2915f095db17cb10bf67d5b3bf67f891d45625
PKG_MAINTAINER:=Steven Barth <steven@midlink.org>
include $(INCLUDE_DIR)/package.mk
diff --git a/package/network/ipv6/odhcp6c/files/dhcpv6.sh b/package/network/ipv6/odhcp6c/files/dhcpv6.sh
index cffb3ec22a..387fa300cc 100755
--- a/package/network/ipv6/odhcp6c/files/dhcpv6.sh
+++ b/package/network/ipv6/odhcp6c/files/dhcpv6.sh
@@ -16,14 +16,16 @@ proto_dhcpv6_init_config() {
proto_config_add_string "iface_dslite"
proto_config_add_string "ifaceid"
proto_config_add_string "sourcerouting"
+ proto_config_add_string "userclass"
+ proto_config_add_string "vendorclass"
}
proto_dhcpv6_setup() {
local config="$1"
local iface="$2"
- local reqaddress reqprefix clientid reqopts noslaaconly forceprefix norelease ip6prefix iface_dslite ifaceid sourcerouting
- json_get_vars reqaddress reqprefix clientid reqopts noslaaconly forceprefix norelease ip6prefix iface_dslite ifaceid sourcerouting
+ local reqaddress reqprefix clientid reqopts noslaaconly forceprefix norelease ip6prefix iface_dslite ifaceid sourcerouting userclass vendorclass
+ json_get_vars reqaddress reqprefix clientid reqopts noslaaconly forceprefix norelease ip6prefix iface_dslite ifaceid sourcerouting userclass vendorclass
# Configure
@@ -43,6 +45,10 @@ proto_dhcpv6_setup() {
[ -n "$ifaceid" ] && append opts "-i$ifaceid"
+ [ -n "$vendorclass" ] && append opts "-V$vendorclass"
+
+ [ -n "$userclass" ] && append opts "-u$userclass"
+
for opt in $reqopts; do
append opts "-r$opt"
done