aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2016-04-17 12:51:57 +0000
committerHauke Mehrtens <hauke@openwrt.org>2016-04-17 12:51:57 +0000
commite2a446f079c8a2262c6db2357331a2656b770dac (patch)
treee36b4a177662454b6b8977974cd60f15e20b94e8 /package/network/utils
parentf50456819e962e502eb51066b519ba1de75104f6 (diff)
downloadmaster-187ad058-e2a446f079c8a2262c6db2357331a2656b770dac.tar.gz
master-187ad058-e2a446f079c8a2262c6db2357331a2656b770dac.tar.bz2
master-187ad058-e2a446f079c8a2262c6db2357331a2656b770dac.zip
curl: add flags to allow gc-sections to strip out unused code
Signed-off-by: Dirk Feytons <dirk.feytons@gmail.com> Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@49184 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/utils')
-rw-r--r--package/network/utils/curl/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/network/utils/curl/Makefile b/package/network/utils/curl/Makefile
index 319c0b710d..af38ed4aed 100644
--- a/package/network/utils/curl/Makefile
+++ b/package/network/utils/curl/Makefile
@@ -99,8 +99,9 @@ define Package/libcurl/config
source "$(SOURCE)/Config.in"
endef
-TARGET_CFLAGS += $(FPIC)
+TARGET_CFLAGS += $(FPIC) -ffunction-sections -fdata-sections
TARGET_CPPFLAGS += $(if $(CONFIG_LIBCURL_NTLM),,-DCURL_DISABLE_NTLM)
+TARGET_LDFLAGS += -Wl,--gc-sections
CONFIGURE_ARGS += \
--disable-debug \