aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/iproute2
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2014-06-17 12:43:30 +0000
committerSteven Barth <steven@midlink.org>2014-06-17 12:43:30 +0000
commitb0147d9e5b13fe68eaa471508999227b3270d287 (patch)
tree07badfe9e86cc153180e7cb9f1b7800ef12fbcbf /package/network/utils/iproute2
parentabd3b2c90e584225487224912da04aa516f2b514 (diff)
downloadmaster-187ad058-b0147d9e5b13fe68eaa471508999227b3270d287.tar.gz
master-187ad058-b0147d9e5b13fe68eaa471508999227b3270d287.tar.bz2
master-187ad058-b0147d9e5b13fe68eaa471508999227b3270d287.zip
iproute2: update version to 3.15.0, refresh patches, add maintainer
Signed-off-by: Russell Senior <russell@personaltelco.net> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41227 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/utils/iproute2')
-rw-r--r--package/network/utils/iproute2/Makefile9
-rw-r--r--package/network/utils/iproute2/patches/006-no_sctp.patch4
-rw-r--r--package/network/utils/iproute2/patches/110-extra-ccopts.patch2
-rw-r--r--package/network/utils/iproute2/patches/200-add-tc_esfq.patch2
-rw-r--r--package/network/utils/iproute2/patches/210-add-act_connmark.patch4
-rw-r--r--package/network/utils/iproute2/patches/300-ip_tiny.patch4
6 files changed, 13 insertions, 12 deletions
diff --git a/package/network/utils/iproute2/Makefile b/package/network/utils/iproute2/Makefile
index 7cc2fb43c7..558855ff4c 100644
--- a/package/network/utils/iproute2/Makefile
+++ b/package/network/utils/iproute2/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2013 OpenWrt.org
+# Copyright (C) 2006-2014 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=iproute2
-PKG_VERSION:=3.11.0
+PKG_VERSION:=3.15.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=http://kernel.org/pub/linux/utils/net/iproute2/
-PKG_MD5SUM:=d7ffb27bc9f0d80577b1f3fb9d1a7689
+PKG_MD5SUM:=5b1711c9d16071959052e369a2682d77
PKG_BUILD_PARALLEL:=1
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
@@ -24,8 +24,9 @@ define Package/iproute2/Default
TITLE:=Routing control utility ($(2))
SECTION:=net
CATEGORY:=Network
- URL:=http://linux-net.osdl.org/index.php/Iproute2
+ URL:=http://www.linuxfoundation.org/collaborate/workgroups/networking/iproute2
SUBMENU:=Routing and Redirection
+ MAINTAINER:=Russell Senior <russell@personaltelco.net>
DEPENDS:= +libnl-tiny
VARIANT:=$(1)
endef
diff --git a/package/network/utils/iproute2/patches/006-no_sctp.patch b/package/network/utils/iproute2/patches/006-no_sctp.patch
index a3ed890450..d4a0de00a5 100644
--- a/package/network/utils/iproute2/patches/006-no_sctp.patch
+++ b/package/network/utils/iproute2/patches/006-no_sctp.patch
@@ -1,6 +1,6 @@
--- a/ip/ipxfrm.c
+++ b/ip/ipxfrm.c
-@@ -470,7 +470,6 @@ void xfrm_selector_print(struct xfrm_sel
+@@ -469,7 +469,6 @@ void xfrm_selector_print(struct xfrm_sel
switch (sel->proto) {
case IPPROTO_TCP:
case IPPROTO_UDP:
@@ -8,7 +8,7 @@
case IPPROTO_DCCP:
default: /* XXX */
if (sel->sport_mask)
-@@ -1283,7 +1282,6 @@ static int xfrm_selector_upspec_parse(st
+@@ -1282,7 +1281,6 @@ static int xfrm_selector_upspec_parse(st
switch (sel->proto) {
case IPPROTO_TCP:
case IPPROTO_UDP:
diff --git a/package/network/utils/iproute2/patches/110-extra-ccopts.patch b/package/network/utils/iproute2/patches/110-extra-ccopts.patch
index 4a08757bd9..0e36230012 100644
--- a/package/network/utils/iproute2/patches/110-extra-ccopts.patch
+++ b/package/network/utils/iproute2/patches/110-extra-ccopts.patch
@@ -7,5 +7,5 @@
-CCOPTS = -O2
+CCOPTS = -O2 $(EXTRA_CCOPTS)
WFLAGS := -Wall -Wstrict-prototypes -Wmissing-prototypes
- WFLAGS += -Wmissing-declarations -Wold-style-definition
+ WFLAGS += -Wmissing-declarations -Wold-style-definition -Wformat=2
diff --git a/package/network/utils/iproute2/patches/200-add-tc_esfq.patch b/package/network/utils/iproute2/patches/200-add-tc_esfq.patch
index f09b45004f..19d819974b 100644
--- a/package/network/utils/iproute2/patches/200-add-tc_esfq.patch
+++ b/package/network/utils/iproute2/patches/200-add-tc_esfq.patch
@@ -10,7 +10,7 @@
TCMODULES += q_tbf.o
--- a/include/linux/pkt_sched.h
+++ b/include/linux/pkt_sched.h
-@@ -222,6 +222,33 @@ struct tc_sfq_xstats {
+@@ -226,6 +226,33 @@ struct tc_sfq_xstats {
__s32 allot;
};
diff --git a/package/network/utils/iproute2/patches/210-add-act_connmark.patch b/package/network/utils/iproute2/patches/210-add-act_connmark.patch
index ac6ba33792..c0bf07aadd 100644
--- a/package/network/utils/iproute2/patches/210-add-act_connmark.patch
+++ b/package/network/utils/iproute2/patches/210-add-act_connmark.patch
@@ -1,13 +1,13 @@
--- a/tc/Makefile
+++ b/tc/Makefile
-@@ -38,6 +38,7 @@ TCMODULES += m_mirred.o
+@@ -39,6 +39,7 @@ TCMODULES += m_mirred.o
TCMODULES += m_nat.o
TCMODULES += m_pedit.o
TCMODULES += m_skbedit.o
+TCMODULES += m_connmark.o
TCMODULES += m_csum.o
+ TCMODULES += m_simple.o
TCMODULES += p_ip.o
- TCMODULES += p_icmp.o
--- /dev/null
+++ b/tc/m_connmark.c
@@ -0,0 +1,74 @@
diff --git a/package/network/utils/iproute2/patches/300-ip_tiny.patch b/package/network/utils/iproute2/patches/300-ip_tiny.patch
index 43afb9c848..5b0d56c114 100644
--- a/package/network/utils/iproute2/patches/300-ip_tiny.patch
+++ b/package/network/utils/iproute2/patches/300-ip_tiny.patch
@@ -14,7 +14,7 @@
ALLOBJ=$(IPOBJ) $(RTMONOBJ)
SCRIPTS=ifcfg rtpr routel routef
TARGETS=ip rtmon
-@@ -43,7 +50,7 @@ else
+@@ -42,7 +49,7 @@ else
ip: static-syms.o
static-syms.o: static-syms.h
@@ -28,7 +28,7 @@
@@ -66,29 +66,41 @@ static const struct cmd {
int (*func)(int argc, char **argv);
} cmds[] = {
- { "address", do_ipaddr },
+ { "address", do_ipaddr },
+#ifndef IPROUTE2_TINY
{ "addrlabel", do_ipaddrlabel },
+#endif