aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/iproute2
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-10-30 15:20:41 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-10-30 15:20:41 +0000
commit771b32ba2bc5ce40a60a029157ae2edc42dac000 (patch)
tree24b13d6884c884d800310487f1e2a508cd9db9ad /package/network/utils/iproute2
parentf666ce40f8d717986f9695f03a175cff8534e2ff (diff)
downloadmaster-187ad058-771b32ba2bc5ce40a60a029157ae2edc42dac000.tar.gz
master-187ad058-771b32ba2bc5ce40a60a029157ae2edc42dac000.tar.bz2
master-187ad058-771b32ba2bc5ce40a60a029157ae2edc42dac000.zip
iproute2: fix compile with uClibc-ng
Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47291 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/utils/iproute2')
-rw-r--r--package/network/utils/iproute2/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/network/utils/iproute2/Makefile b/package/network/utils/iproute2/Makefile
index 23834dfd24..f5b5f4e536 100644
--- a/package/network/utils/iproute2/Makefile
+++ b/package/network/utils/iproute2/Makefile
@@ -84,6 +84,9 @@ endif
ifdef CONFIG_USE_MUSL
TARGET_CFLAGS += -DHAVE_SETNS
endif
+ifdef CONFIG_UCLIBC_USE_VERSION_NG
+ TARGET_CFLAGS += -DHAVE_SETNS
+endif
TARGET_CFLAGS += -ffunction-sections -fdata-sections