aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/iproute2
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2015-01-17 10:58:34 +0000
committerSteven Barth <steven@midlink.org>2015-01-17 10:58:34 +0000
commit1a05e464861175ffa2cd7e8c55740e1c141cae58 (patch)
tree922c3fde5f4642616c8f6429eb01893572f64e33 /package/network/utils/iproute2
parentdb806121a3a185daf21cb0d396f3d1c9d2e56d5c (diff)
downloadmaster-187ad058-1a05e464861175ffa2cd7e8c55740e1c141cae58.tar.gz
master-187ad058-1a05e464861175ffa2cd7e8c55740e1c141cae58.tar.bz2
master-187ad058-1a05e464861175ffa2cd7e8c55740e1c141cae58.zip
iproute2: add package for bridge program
The 'bridge' program has been part of iproute2 for a while, and it was once declared[1] to the the intended longterm replacement for bridge-utils, but its features are still mostly distinct[2] from the venerable brctl. [1] http://lwn.net/Articles/435845/ [2] http://sgros-students.blogspot.com/2013/11/comparison-of-brctl-and-bridge-commands.html Signed-off-by: Russell Senior <russell@personaltelco.net> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43993 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/utils/iproute2')
-rw-r--r--package/network/utils/iproute2/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/package/network/utils/iproute2/Makefile b/package/network/utils/iproute2/Makefile
index a49b0616ea..ad14ac4484 100644
--- a/package/network/utils/iproute2/Makefile
+++ b/package/network/utils/iproute2/Makefile
@@ -58,6 +58,11 @@ $(call Package/iproute2/Default)
TITLE:=General netlink utility frontend
endef
+define Package/ip-bridge
+$(call Package/iproute2/Default)
+ TITLE:=Bridge configuration utility from iproute2
+endef
+
define Package/ss
$(call Package/iproute2/Default)
TITLE:=Socket statistics utility
@@ -130,6 +135,11 @@ define Package/genl/install
$(INSTALL_BIN) $(PKG_BUILD_DIR)/genl/genl $(1)/usr/sbin/
endef
+define Package/ip-bridge/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/bridge/bridge $(1)/usr/sbin/
+endef
+
define Package/ss/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/misc/ss $(1)/usr/sbin/
@@ -139,4 +149,5 @@ $(eval $(call BuildPackage,ip))
$(eval $(call BuildPackage,ip-full))
$(eval $(call BuildPackage,tc))
$(eval $(call BuildPackage,genl))
+$(eval $(call BuildPackage,ip-bridge))
$(eval $(call BuildPackage,ss))