aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/ebtables/patches
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2015-02-11 11:31:07 +0000
committerNicolas Thill <nico@openwrt.org>2015-02-11 11:31:07 +0000
commitede8135f37ebddb59cbc3b77a4c8dd206efe4ea1 (patch)
tree570fbc5658d826c202fdee50dccdcc5aba2f4d37 /package/network/utils/ebtables/patches
parentdf3803364771849cc73f155e1dc74f9867263e15 (diff)
downloadmaster-187ad058-ede8135f37ebddb59cbc3b77a4c8dd206efe4ea1.tar.gz
master-187ad058-ede8135f37ebddb59cbc3b77a4c8dd206efe4ea1.tar.bz2
master-187ad058-ede8135f37ebddb59cbc3b77a4c8dd206efe4ea1.zip
ebtables: disable rpath
Signed-off-by: Nicolas Thill <nico@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44396 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/utils/ebtables/patches')
-rw-r--r--package/network/utils/ebtables/patches/001-no_rpath.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/package/network/utils/ebtables/patches/001-no_rpath.patch b/package/network/utils/ebtables/patches/001-no_rpath.patch
new file mode 100644
index 0000000000..d4c13f620b
--- /dev/null
+++ b/package/network/utils/ebtables/patches/001-no_rpath.patch
@@ -0,0 +1,30 @@
+--- a/Makefile
++++ b/Makefile
+@@ -90,8 +90,7 @@ libebtc.so: $(OBJECTS2)
+ $(CC) -shared $(LDFLAGS) -Wl,-soname,libebtc.so -o libebtc.so -lc $(OBJECTS2)
+
+ ebtables: $(OBJECTS) ebtables-standalone.o libebtc.so
+- $(CC) $(CFLAGS) $(CFLAGS_SH_LIB) $(LDFLAGS) -o $@ ebtables-standalone.o -I$(KERNEL_INCLUDES) -L. -Lextensions -lebtc $(EXT_LIBSI) \
+- -Wl,-rpath,$(LIBDIR)
++ $(CC) $(CFLAGS) $(CFLAGS_SH_LIB) $(LDFLAGS) -o $@ ebtables-standalone.o -I$(KERNEL_INCLUDES) -L. -Lextensions -lebtc $(EXT_LIBSI)
+
+ ebtablesu: ebtablesu.c
+ $(CC) $(CFLAGS) $(PROGSPECSD) $< -o $@
+@@ -100,15 +99,13 @@ ebtablesd.o: ebtablesd.c include/ebtable
+ $(CC) $(CFLAGS) $(PROGSPECSD) -c $< -o $@ -I$(KERNEL_INCLUDES)
+
+ ebtablesd: $(OBJECTS) ebtablesd.o libebtc.so
+- $(CC) $(CFLAGS) -o $@ ebtablesd.o -I$(KERNEL_INCLUDES) -L. -Lextensions -lebtc $(EXT_LIBSI) \
+- -Wl,-rpath,$(LIBDIR)
++ $(CC) $(CFLAGS) -o $@ ebtablesd.o -I$(KERNEL_INCLUDES) -L. -Lextensions -lebtc $(EXT_LIBSI)
+
+ ebtables-restore.o: ebtables-restore.c include/ebtables_u.h
+ $(CC) $(CFLAGS) $(PROGSPECS) -c $< -o $@ -I$(KERNEL_INCLUDES)
+
+ ebtables-restore: $(OBJECTS) ebtables-restore.o libebtc.so
+- $(CC) $(CFLAGS) $(LDFLAGS) -o $@ ebtables-restore.o -I$(KERNEL_INCLUDES) -L. -Lextensions -lebtc $(EXT_LIBSI) \
+- -Wl,-rpath,$(LIBDIR)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ ebtables-restore.o -I$(KERNEL_INCLUDES) -L. -Lextensions -lebtc $(EXT_LIBSI)
+
+ .PHONY: daemon
+ daemon: ebtablesd ebtablesu