aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/curl/patches
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2016-04-17 12:51:19 +0000
committerHauke Mehrtens <hauke@openwrt.org>2016-04-17 12:51:19 +0000
commit50ac5bb17e71f9f31e8ff67b8f61a97294225959 (patch)
tree28918f012b28a9cd2bf466f0ef4906cf25f39ca6 /package/network/utils/curl/patches
parent5e695bd0862e5e7ea599c489d57e714fdf826c25 (diff)
downloadmaster-187ad058-50ac5bb17e71f9f31e8ff67b8f61a97294225959.tar.gz
master-187ad058-50ac5bb17e71f9f31e8ff67b8f61a97294225959.tar.bz2
master-187ad058-50ac5bb17e71f9f31e8ff67b8f61a97294225959.zip
curl: upstep to latest version 7.48.0
Signed-off-by: Dirk Feytons <dirk.feytons@gmail.com> Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@49182 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/utils/curl/patches')
-rw-r--r--package/network/utils/curl/patches/200-no_docs_tests.patch4
-rw-r--r--package/network/utils/curl/patches/300-fix-disable-crypto-auth.patch2
-rw-r--r--package/network/utils/curl/patches/310-polarssl-disable-runtime-version-check.patch2
3 files changed, 4 insertions, 4 deletions
diff --git a/package/network/utils/curl/patches/200-no_docs_tests.patch b/package/network/utils/curl/patches/200-no_docs_tests.patch
index 5db39258d0..4ac5badf60 100644
--- a/package/network/utils/curl/patches/200-no_docs_tests.patch
+++ b/package/network/utils/curl/patches/200-no_docs_tests.patch
@@ -1,6 +1,6 @@
--- a/Makefile.am
+++ b/Makefile.am
-@@ -141,7 +141,7 @@ CLEANFILES = $(VC6_LIBDSP) $(VC6_SRCDSP)
+@@ -150,7 +150,7 @@ CLEANFILES = $(VC6_LIBDSP) $(VC6_SRCDSP)
bin_SCRIPTS = curl-config
SUBDIRS = lib src include scripts
@@ -11,7 +11,7 @@
pkgconfig_DATA = libcurl.pc
--- a/Makefile.in
+++ b/Makefile.in
-@@ -601,7 +601,7 @@ CLEANFILES = $(VC6_LIBDSP) $(VC6_SRCDSP)
+@@ -611,7 +611,7 @@ CLEANFILES = $(VC6_LIBDSP) $(VC6_SRCDSP)
bin_SCRIPTS = curl-config
SUBDIRS = lib src include scripts
diff --git a/package/network/utils/curl/patches/300-fix-disable-crypto-auth.patch b/package/network/utils/curl/patches/300-fix-disable-crypto-auth.patch
index abec7ad912..5c0a37e760 100644
--- a/package/network/utils/curl/patches/300-fix-disable-crypto-auth.patch
+++ b/package/network/utils/curl/patches/300-fix-disable-crypto-auth.patch
@@ -1,6 +1,6 @@
--- a/lib/curl_ntlm_msgs.c
+++ b/lib/curl_ntlm_msgs.c
-@@ -569,7 +569,7 @@ CURLcode Curl_sasl_create_ntlm_type3_mes
+@@ -573,7 +573,7 @@ CURLcode Curl_sasl_create_ntlm_type3_mes
else
#endif
diff --git a/package/network/utils/curl/patches/310-polarssl-disable-runtime-version-check.patch b/package/network/utils/curl/patches/310-polarssl-disable-runtime-version-check.patch
index 6f9cf2e998..7f7937b950 100644
--- a/package/network/utils/curl/patches/310-polarssl-disable-runtime-version-check.patch
+++ b/package/network/utils/curl/patches/310-polarssl-disable-runtime-version-check.patch
@@ -11,7 +11,7 @@
version>>24, (version>>16)&0xff, (version>>8)&0xff);
--- a/lib/vtls/mbedtls.c
+++ b/lib/vtls/mbedtls.c
-@@ -686,7 +686,7 @@ void Curl_mbedtls_session_free(void *ptr
+@@ -712,7 +712,7 @@ void Curl_mbedtls_session_free(void *ptr
size_t Curl_mbedtls_version(char *buffer, size_t size)
{