aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/uhttpd
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-10-07 22:14:48 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-10-07 22:14:48 +0000
commitff10ea53ec3a3451fd03331d11790ff98fd312a7 (patch)
tree4fb5a7565e0d9e66245336504dfa6cd8422ae076 /package/network/services/uhttpd
parentbc54d063dda75cc953630bb63b2fd330a2d39435 (diff)
downloadmaster-187ad058-ff10ea53ec3a3451fd03331d11790ff98fd312a7.tar.gz
master-187ad058-ff10ea53ec3a3451fd03331d11790ff98fd312a7.tar.bz2
master-187ad058-ff10ea53ec3a3451fd03331d11790ff98fd312a7.zip
uhttpd: fix keep-alive bug (#20607, #20661)
The two commits 5162e3b0ee7bd1d0fd6e75e1ca7993a1834b5291 "allow request handlers to disable chunked reponses" and 618493e378e2239f0d30902e47adfa134e649fdc "file: disable chunked encoding for file responses" broke the chunked transfer encoding handling for proc responses in keep-alive connections that followed a file response with http status 204 or 304. The effect of this bug is that cgi responses following a 204 or 304 one where sent neither in chunked encoding nor with a content-length header, causing browsers to stall until the keep alive timeout was reached. Fix the logic flaw by inverting the chunk prevention flag in the client state and by testing the chunked encoding preconditions every time instead of once upon client (re-)initialization. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47161 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/services/uhttpd')
-rw-r--r--package/network/services/uhttpd/Makefile4
-rwxr-xr-xpackage/network/services/uhttpd/files/uhttpd.init5
2 files changed, 2 insertions, 7 deletions
diff --git a/package/network/services/uhttpd/Makefile b/package/network/services/uhttpd/Makefile
index 51f2bdc1ce..a9a535aee8 100644
--- a/package/network/services/uhttpd/Makefile
+++ b/package/network/services/uhttpd/Makefile
@@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=uhttpd
-PKG_VERSION:=2015-09-07
+PKG_VERSION:=2015-10-08
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://nbd.name/uhttpd2.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=993cace15114a0f06f720f34a4748ab54b695f0d
+PKG_SOURCE_VERSION:=7ed2edc40dd6d0171266f3bfbc96466e1d25e3cd
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
PKG_LICENSE:=ISC
diff --git a/package/network/services/uhttpd/files/uhttpd.init b/package/network/services/uhttpd/files/uhttpd.init
index 1ebe38e8d3..a3e09c44e7 100755
--- a/package/network/services/uhttpd/files/uhttpd.init
+++ b/package/network/services/uhttpd/files/uhttpd.init
@@ -131,11 +131,6 @@ start_instance()
}
procd_close_instance
-
- # Check if daemon is running, if not then
- # re-execute in foreground to display error.
-# sleep 1 && service_check $UHTTPD_BIN || \
-# $UHTTPD_BIN -f $UHTTPD_ARGS
}
service_triggers()