aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/config/soloscli/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2012-10-17 22:45:58 +0000
committerJohn Crispin <blogic@openwrt.org>2012-10-17 22:45:58 +0000
commit16ed01db05cf25221a62baf3c8eba135f933a6b1 (patch)
tree405d52924fbc92967e8681bcca5e9c17d35aab8c /package/network/config/soloscli/Makefile
parent2372b1dbdb253065274b8a54846149d634bcea14 (diff)
downloadmaster-187ad058-16ed01db05cf25221a62baf3c8eba135f933a6b1.tar.gz
master-187ad058-16ed01db05cf25221a62baf3c8eba135f933a6b1.tar.bz2
master-187ad058-16ed01db05cf25221a62baf3c8eba135f933a6b1.zip
[kernel] move lots of kernel related packages to the new system/ folder
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33830 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/config/soloscli/Makefile')
-rw-r--r--package/network/config/soloscli/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/package/network/config/soloscli/Makefile b/package/network/config/soloscli/Makefile
new file mode 100644
index 0000000000..9a7cd894f9
--- /dev/null
+++ b/package/network/config/soloscli/Makefile
@@ -0,0 +1,45 @@
+#
+# Copyright (C) 2006-2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=soloscli
+PKG_VERSION:=0.11
+PKG_RELEASE:=3
+
+PKG_SOURCE:=solos-pci-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/openadsl
+PKG_MD5SUM:=ab3f3fa654ef7c3a402980eca094e690
+
+PKG_INSTALL:=1
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/solos-pci-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/soloscli
+ SECTION:=net
+ CATEGORY:=Network
+ TITLE:=Configuration utility for Solos ADSL2+ modems
+ DEPENDS:=+kmod-solos-pci
+ URL:=http://sourceforge.net/projects/openadsl
+endef
+
+define Package/soloscli/description
+ This package contains the soloscli utility
+ for interrogating Traverse Technologies' Solos ADSL2+ modems.
+endef
+
+define Package/soloscli/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/soloscli/soloscli $(1)/usr/bin/
+ $(INSTALL_BIN) ./files/solos-log-stats $(1)/usr/bin/
+ $(INSTALL_DIR) $(1)/etc/hotplug.d/atm
+ $(INSTALL_DATA) ./files/etc/hotplug.d/atm/15-solos-init $(1)/etc/hotplug.d/atm/
+endef
+
+$(eval $(call BuildPackage,soloscli))