aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/config/firewall3/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2013-03-05 13:45:09 +0000
committerJo-Philipp Wich <jow@openwrt.org>2013-03-05 13:45:09 +0000
commit58e4a0f3460a5be6dd9a9526e053c255ef4eea4a (patch)
treeb69c134fa6314cb2d3a6dd2181af912902e90975 /package/network/config/firewall3/Makefile
parentc31da129f792cca65c8f329aaf8a6dccbc1e32f5 (diff)
downloadmaster-187ad058-58e4a0f3460a5be6dd9a9526e053c255ef4eea4a.tar.gz
master-187ad058-58e4a0f3460a5be6dd9a9526e053c255ef4eea4a.tar.bz2
master-187ad058-58e4a0f3460a5be6dd9a9526e053c255ef4eea4a.zip
firewall3: add default config and firewall.user
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35889 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/config/firewall3/Makefile')
-rw-r--r--package/network/config/firewall3/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/package/network/config/firewall3/Makefile b/package/network/config/firewall3/Makefile
index 66da421327..cd9405eae4 100644
--- a/package/network/config/firewall3/Makefile
+++ b/package/network/config/firewall3/Makefile
@@ -33,6 +33,11 @@ define Package/firewall3/description
This package provides a config-compatible C implementation of the UCI firewall.
endef
+define Package/firewall3/conffiles
+/etc/config/firewall
+/etc/firewall.user
+endef
+
define Package/firewall3/install
$(INSTALL_DIR) $(1)/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/firewall3 $(1)/sbin/fw3
@@ -40,6 +45,10 @@ define Package/firewall3/install
$(INSTALL_BIN) ./files/firewall.init $(1)/etc/init.d/firewall
$(INSTALL_DIR) $(1)/etc/hotplug.d/iface
$(INSTALL_DATA) ./files/firewall.hotplug $(1)/etc/hotplug.d/iface/20-firewall
+ $(INSTALL_DIR) $(1)/etc/config/
+ $(INSTALL_DATA) ./files/firewall.config $(1)/etc/config/firewall
+ $(INSTALL_DIR) $(1)/etc/
+ $(INSTALL_DATA) ./files/firewall.user $(1)/etc/firewall.user
endef
$(eval $(call BuildPackage,firewall3))