aboutsummaryrefslogtreecommitdiffstats
path: root/package/ncurses
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-04-08 09:08:38 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-04-08 09:08:38 +0000
commite295e9cf7cfbd7f30c932549588867c137c9d103 (patch)
tree463c013e23557a5b9082ada45a3d7b583857450e /package/ncurses
parent767792e7a621d580a23e8ba0df1bf2c1f664f744 (diff)
downloadmaster-187ad058-e295e9cf7cfbd7f30c932549588867c137c9d103.tar.gz
master-187ad058-e295e9cf7cfbd7f30c932549588867c137c9d103.tar.bz2
master-187ad058-e295e9cf7cfbd7f30c932549588867c137c9d103.zip
add some fixes for parallel build (does not work with -j4 yet, but it gets most packages compiled now)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@577 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/ncurses')
-rw-r--r--package/ncurses/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/ncurses/Makefile b/package/ncurses/Makefile
index 3835af6c1a..3d73e7747f 100644
--- a/package/ncurses/Makefile
+++ b/package/ncurses/Makefile
@@ -20,6 +20,8 @@ PKG_SOURCE_DIR := $(PKG_NAME)-$(PKG_VERSION)
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_SOURCE_DIR)
PKG_IPK := $(PACKAGE_DIR)/lib$(PKG_NAME)_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
+.NOTPARALLEL:
+
$(DL_DIR)/$(PKG_SOURCE_FILE):
mkdir -p $(DL_DIR)
$(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE_FILE) $(PKG_MD5SUM) $(PKG_SOURCE_SITE)
@@ -35,7 +37,7 @@ $(PKG_IPK): $(PKG_BUILD_DIR)/ipkg/rules
cd $(PKG_BUILD_DIR); \
TOPDIR="$(TOPDIR)" IPKG_RULES_INC="$(TOPDIR)/rules.mk" \
INSTALL_DIR="$(STAGING_DIR)" \
- ./ipkg/rules package
+ $(MAKE) -j1 -f ./ipkg/rules package
$(IPKG_STATE_DIR)/info/lib$(PKG_NAME).list: $(PKG_IPK)
$(IPKG) install $(PKG_IPK)