aboutsummaryrefslogtreecommitdiffstats
path: root/package/madwifi-tools
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-08-25 11:59:22 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-08-25 11:59:22 +0000
commite3d4482e20050069477b68c68ceb9a28593ae882 (patch)
tree01177721a7a09666d181cceb6776894a38f99ec2 /package/madwifi-tools
parente07a9f98817edcc4fd988ea72584474c3395c7e6 (diff)
downloadmaster-187ad058-e3d4482e20050069477b68c68ceb9a28593ae882.tar.gz
master-187ad058-e3d4482e20050069477b68c68ceb9a28593ae882.tar.bz2
master-187ad058-e3d4482e20050069477b68c68ceb9a28593ae882.zip
add madwifi-tools
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1751 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/madwifi-tools')
-rw-r--r--package/madwifi-tools/Config.in6
-rw-r--r--package/madwifi-tools/Makefile38
-rw-r--r--package/madwifi-tools/ipkg/madwifi-tools.control6
3 files changed, 50 insertions, 0 deletions
diff --git a/package/madwifi-tools/Config.in b/package/madwifi-tools/Config.in
new file mode 100644
index 0000000000..30f3563830
--- /dev/null
+++ b/package/madwifi-tools/Config.in
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_MADWIFI_TOOLS
+ prompt "madwifi-tools - utilities for configuring the Atheros Wifi driver"
+ tristate
+ default m if CONFIG_DEVEL
+ help
+ Driver utilities for Atheros 802.11a/b/g MiniPCI cards
diff --git a/package/madwifi-tools/Makefile b/package/madwifi-tools/Makefile
new file mode 100644
index 0000000000..a7afde1cf2
--- /dev/null
+++ b/package/madwifi-tools/Makefile
@@ -0,0 +1,38 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=madwifi
+PKG_VERSION:=2005-08-13
+PKG_RELEASE:=1
+PKG_MD5SUM:=188127127aebd8815595c025a787d729
+
+PKG_SOURCE_URL:=http://madwifi.otaku42.de/2005/08/
+PKG_SOURCE:=$(PKG_NAME)-cvs-snapshot-$(PKG_VERSION).tar.bz2
+PKG_CAT:=bzcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,MADWIFI_TOOLS,madwifi-tools,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH),kmod-madwifi))
+
+$(PKG_BUILD_DIR)/.configured:
+ touch $@
+
+$(PKG_BUILD_DIR)/.built:
+ $(MAKE) -C $(PKG_BUILD_DIR)/tools \
+ $(TARGET_CONFIGURE_OPTS)
+ touch $@
+
+$(IPKG_MADWIFI_TOOLS):
+ mkdir -p $(IDIR_MADWIFI_TOOLS)/usr/sbin
+ cp -fpR $(PKG_BUILD_DIR)/tools/athstats \
+ $(PKG_BUILD_DIR)/tools/athdebug \
+ $(PKG_BUILD_DIR)/tools/80211stats \
+ $(PKG_BUILD_DIR)/tools/80211debug \
+ $(PKG_BUILD_DIR)/tools/athctrl \
+ $(PKG_BUILD_DIR)/tools/athkey \
+ $(IDIR_MADWIFI_TOOLS)/usr/sbin
+ $(RSTRIP) $(IDIR_MADWIFI_TOOLS)
+ $(IPKG_BUILD) $(IDIR_MADWIFI_TOOLS) $(PACKAGE_DIR)
diff --git a/package/madwifi-tools/ipkg/madwifi-tools.control b/package/madwifi-tools/ipkg/madwifi-tools.control
new file mode 100644
index 0000000000..de46b73761
--- /dev/null
+++ b/package/madwifi-tools/ipkg/madwifi-tools.control
@@ -0,0 +1,6 @@
+Package: madwifi-tools
+Priority: optional
+Section: net
+Maintainer: Felix Fietkau <openwrt@nbd.name>
+Source: buildroot internal
+Description: Driver utilities for Atheros 802.11a/b/g MiniPCI cards