aboutsummaryrefslogtreecommitdiffstats
path: root/package/mac80211/patches
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2010-02-19 15:41:55 +0000
committerHauke Mehrtens <hauke@openwrt.org>2010-02-19 15:41:55 +0000
commit93c148c54c209e228dfe959df21f3eb45418eeb4 (patch)
tree6710e3ce9222d998f0eadfdfd9fb04bec7b62927 /package/mac80211/patches
parentf0e60800b4fce53b557f80831714f075609f8787 (diff)
downloadmaster-187ad058-93c148c54c209e228dfe959df21f3eb45418eeb4.tar.gz
master-187ad058-93c148c54c209e228dfe959df21f3eb45418eeb4.tar.bz2
master-187ad058-93c148c54c209e228dfe959df21f3eb45418eeb4.zip
[mac80211] remove pcmcia and sdio
This fixes #6701 Remove the pcmcia and sdio interface from b43 driver to not depend on these modules. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19756 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/mac80211/patches')
-rw-r--r--package/mac80211/patches/010-no_pcmcia.patch20
-rw-r--r--package/mac80211/patches/011-no_sdio.patch13
-rw-r--r--package/mac80211/patches/120-linux-2.6.30-compat.patch2
3 files changed, 33 insertions, 2 deletions
diff --git a/package/mac80211/patches/010-no_pcmcia.patch b/package/mac80211/patches/010-no_pcmcia.patch
index 3ef315b3ad..1334dbb141 100644
--- a/package/mac80211/patches/010-no_pcmcia.patch
+++ b/package/mac80211/patches/010-no_pcmcia.patch
@@ -5,7 +5,25 @@
CONFIG_PCI=y
CONFIG_USB=y
- CONFIG_PCMCIA=y
-+ # CONFIG_PCMCIA=y
++# CONFIG_PCMCIA=y
CONFIG_SSB=m
else
include $(KLIB_BUILD)/.config
+@@ -197,7 +197,7 @@ CONFIG_B43=m
+ CONFIG_B43_HWRNG=y
+ CONFIG_B43_PCI_AUTOSELECT=y
+ ifneq ($(CONFIG_PCMCIA),)
+-CONFIG_B43_PCMCIA=y
++# CONFIG_B43_PCMCIA=y
+ endif
+ CONFIG_B43_LEDS=y
+ CONFIG_B43_PHY_LP=y
+@@ -248,7 +248,7 @@ CONFIG_SSB_BLOCKIO=y
+ CONFIG_SSB_PCIHOST=y
+ CONFIG_SSB_B43_PCI_BRIDGE=y
+ ifneq ($(CONFIG_PCMCIA),)
+-CONFIG_SSB_PCMCIAHOST=y
++# CONFIG_SSB_PCMCIAHOST=y
+ endif
+ # CONFIG_SSB_DEBUG=y
+ CONFIG_SSB_DRIVER_PCICORE=y
diff --git a/package/mac80211/patches/011-no_sdio.patch b/package/mac80211/patches/011-no_sdio.patch
new file mode 100644
index 0000000000..aa651edd22
--- /dev/null
+++ b/package/mac80211/patches/011-no_sdio.patch
@@ -0,0 +1,13 @@
+--- a/config.mk
++++ b/config.mk
+@@ -382,8 +382,8 @@ endif # end of SPI driver list
+
+ ifneq ($(CONFIG_MMC),)
+
+-CONFIG_SSB_SDIOHOST=y
+-CONFIG_B43_SDIO=y
++# CONFIG_SSB_SDIOHOST=y
++# CONFIG_B43_SDIO=y
+ CONFIG_WL1251_SDIO=m
+
+ ifdef CONFIG_COMPAT_KERNEL_27
diff --git a/package/mac80211/patches/120-linux-2.6.30-compat.patch b/package/mac80211/patches/120-linux-2.6.30-compat.patch
index de46545116..da5966e153 100644
--- a/package/mac80211/patches/120-linux-2.6.30-compat.patch
+++ b/package/mac80211/patches/120-linux-2.6.30-compat.patch
@@ -1,6 +1,6 @@
--- a/net/wireless/nl80211.c
+++ b/net/wireless/nl80211.c
-@@ -5667,7 +5667,11 @@
+@@ -5662,7 +5662,11 @@ int nl80211_send_action(struct cfg80211_
return err;
}