aboutsummaryrefslogtreecommitdiffstats
path: root/package/mac80211/patches/400-ath_move_debug_code.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-06-15 20:14:06 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-06-15 20:14:06 +0000
commit5fb5b75668de4905edba27be4f503316e298b2e4 (patch)
tree1412b60e597f5cd3c927166f71c0bd3860e2a766 /package/mac80211/patches/400-ath_move_debug_code.patch
parented11b6185b5c087dc4acabf1a43c6b82698169d1 (diff)
downloadmaster-187ad058-5fb5b75668de4905edba27be4f503316e298b2e4.tar.gz
master-187ad058-5fb5b75668de4905edba27be4f503316e298b2e4.tar.bz2
master-187ad058-5fb5b75668de4905edba27be4f503316e298b2e4.zip
mac80211: update to wireless-testing 2013-06-13 + latest backport infrastructure
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36939 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/mac80211/patches/400-ath_move_debug_code.patch')
-rw-r--r--package/mac80211/patches/400-ath_move_debug_code.patch8
1 files changed, 4 insertions, 4 deletions
diff --git a/package/mac80211/patches/400-ath_move_debug_code.patch b/package/mac80211/patches/400-ath_move_debug_code.patch
index c91128db61..a01db3ea9b 100644
--- a/package/mac80211/patches/400-ath_move_debug_code.patch
+++ b/package/mac80211/patches/400-ath_move_debug_code.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/wireless/ath/Makefile
+++ b/drivers/net/wireless/ath/Makefile
-@@ -10,7 +10,7 @@ obj-$(CONFIG_ATH_COMMON) += ath.o
+@@ -11,7 +11,7 @@ obj-$(CPTCFG_ATH_COMMON) += ath.o
ath-objs := main.o \
regd.o \
hw.o \
@@ -8,15 +8,15 @@
+ key.o \
+ debug.o
--ath-$(CONFIG_ATH_DEBUG) += debug.o
+-ath-$(CPTCFG_ATH_DEBUG) += debug.o
ccflags-y += -D__CHECK_ENDIAN__
--- a/drivers/net/wireless/ath/ath.h
+++ b/drivers/net/wireless/ath/ath.h
@@ -281,13 +281,6 @@ void _ath_dbg(struct ath_common *common,
- #endif /* CONFIG_ATH_DEBUG */
+ #endif /* CPTCFG_ATH_DEBUG */
/** Returns string describing opmode, or NULL if unknown mode. */
--#ifdef CONFIG_ATH_DEBUG
+-#ifdef CPTCFG_ATH_DEBUG
const char *ath_opmode_to_string(enum nl80211_iftype opmode);
-#else
-static inline const char *ath_opmode_to_string(enum nl80211_iftype opmode)