aboutsummaryrefslogtreecommitdiffstats
path: root/package/mac80211/patches/130-fix_sublevel_check.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-12-05 14:20:17 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-12-05 14:20:17 +0000
commita95157c262a1c1c75151bbda240f7c107c6a9a53 (patch)
treecc7314ba8bd7c186ce1ad1b7296964fc39c79417 /package/mac80211/patches/130-fix_sublevel_check.patch
parenta86d2fb99b8aad2846a992c8bc08227516a7e87e (diff)
downloadmaster-187ad058-a95157c262a1c1c75151bbda240f7c107c6a9a53.tar.gz
master-187ad058-a95157c262a1c1c75151bbda240f7c107c6a9a53.tar.bz2
master-187ad058-a95157c262a1c1c75151bbda240f7c107c6a9a53.zip
mac80211: update to 2011-12-01
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29436 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/mac80211/patches/130-fix_sublevel_check.patch')
-rw-r--r--package/mac80211/patches/130-fix_sublevel_check.patch4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/mac80211/patches/130-fix_sublevel_check.patch b/package/mac80211/patches/130-fix_sublevel_check.patch
index b233311ab1..9dfa90af32 100644
--- a/package/mac80211/patches/130-fix_sublevel_check.patch
+++ b/package/mac80211/patches/130-fix_sublevel_check.patch
@@ -1,6 +1,6 @@
--- a/config.mk
+++ b/config.mk
-@@ -20,16 +20,16 @@ COMPAT_LATEST_VERSION = 1
+@@ -20,16 +20,16 @@ COMPAT_LATEST_VERSION = 3
KERNEL_VERSION := $(shell $(MAKE) -C $(KLIB_BUILD) kernelversion | sed -n 's/^\([0-9]\)\..*/\1/p')
ifneq ($(KERNEL_VERSION),2)
@@ -19,4 +19,4 @@
+COMPAT_VERSIONS := $(shell I=$(COMPAT_LATEST_VERSION); while [ "$$I" -gt $(COMPAT_KERNEL_SUBLEVEL) ]; do echo $$I; I=$$(($$I - 1)); done)
$(foreach ver,$(COMPAT_VERSIONS),$(eval CONFIG_COMPAT_KERNEL_3_$(ver)=y))
- ifdef CONFIG_COMPAT_KERNEL_2_6_24
+ RHEL_MAJOR := $(shell grep ^RHEL_MAJOR $(KLIB_BUILD)/Makefile | sed -n 's/.*= *\(.*\)/\1/p')