aboutsummaryrefslogtreecommitdiffstats
path: root/package/mac80211/patches/100-disable_pcmcia_compat.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-12-06 14:11:09 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-12-06 14:11:09 +0000
commitaaf2783f6cea1e9381ad8b464e5e86eac85603c6 (patch)
treecc424bf50bfdf1515e0533ff133e895cc0f373a6 /package/mac80211/patches/100-disable_pcmcia_compat.patch
parentb43862ba7b196d8fcf52d1544a0484b4c835da3a (diff)
downloadmaster-187ad058-aaf2783f6cea1e9381ad8b464e5e86eac85603c6.tar.gz
master-187ad058-aaf2783f6cea1e9381ad8b464e5e86eac85603c6.tar.bz2
master-187ad058-aaf2783f6cea1e9381ad8b464e5e86eac85603c6.zip
mac80211: clean up patches, replace patching config.mk with a generated sed expression
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34531 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/mac80211/patches/100-disable_pcmcia_compat.patch')
-rw-r--r--package/mac80211/patches/100-disable_pcmcia_compat.patch65
1 files changed, 0 insertions, 65 deletions
diff --git a/package/mac80211/patches/100-disable_pcmcia_compat.patch b/package/mac80211/patches/100-disable_pcmcia_compat.patch
deleted file mode 100644
index 60927555bb..0000000000
--- a/package/mac80211/patches/100-disable_pcmcia_compat.patch
+++ /dev/null
@@ -1,65 +0,0 @@
---- a/compat/compat-2.6.28.c
-+++ b/compat/compat-2.6.28.c
-@@ -86,7 +86,7 @@ EXPORT_SYMBOL_GPL(usb_poison_urb);
- #endif
- #endif /* CONFIG_USB */
-
--#if defined(CONFIG_PCMCIA) || defined(CONFIG_PCMCIA_MODULE)
-+#if 0
-
- #include <pcmcia/ds.h>
- struct pcmcia_cfg_mem {
---- a/compat/compat-2.6.33.c
-+++ b/compat/compat-2.6.33.c
-@@ -10,7 +10,7 @@
-
- #include <linux/compat.h>
-
--#if defined(CONFIG_PCCARD) || defined(CONFIG_PCCARD_MODULE)
-+#if 0
-
- /**
- * pccard_loop_tuple() - loop over tuples in the CIS
-@@ -72,7 +72,7 @@ next_entry:
- EXPORT_SYMBOL_GPL(pccard_loop_tuple);
- /* Source: drivers/pcmcia/cistpl.c */
-
--#if defined(CONFIG_PCMCIA) || defined(CONFIG_PCMCIA_MODULE)
-+#if 0
-
- struct pcmcia_loop_mem {
- struct pcmcia_device *p_dev;
---- a/include/linux/compat-2.6.28.h
-+++ b/include/linux/compat-2.6.28.h
-@@ -49,7 +49,7 @@ typedef u32 phys_addr_t;
- })
- #endif /* From include/asm-generic/bug.h */
-
--#if defined(CONFIG_PCMCIA) || defined(CONFIG_PCMCIA_MODULE)
-+#if 0
-
- #include <pcmcia/cs_types.h>
- #include <pcmcia/cs.h>
---- a/include/linux/compat-2.6.33.h
-+++ b/include/linux/compat-2.6.33.h
-@@ -7,7 +7,7 @@
-
- #include <linux/skbuff.h>
- #include <linux/pci.h>
--#if defined(CONFIG_PCCARD) || defined(CONFIG_PCCARD_MODULE)
-+#if 0
- #include <pcmcia/cs_types.h>
- #include <pcmcia/cistpl.h>
- #include <pcmcia/ds.h>
-@@ -82,9 +82,9 @@ static inline struct sk_buff *netdev_all
- return skb;
- }
-
--#if defined(CONFIG_PCCARD) || defined(CONFIG_PCCARD_MODULE)
-+#if 0
-
--#if defined(CONFIG_PCMCIA) || defined(CONFIG_PCMCIA_MODULE)
-+#if 0
-
- #define pcmcia_request_window(a, b, c) pcmcia_request_window(&a, b, c)
-