aboutsummaryrefslogtreecommitdiffstats
path: root/package/mac80211/patches/002-disable_rfkill.patch
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2011-06-15 21:16:38 +0000
committerHauke Mehrtens <hauke@openwrt.org>2011-06-15 21:16:38 +0000
commitb8f56104dc472be555ad2b83f92c1e210eb61a5f (patch)
treea181a9680f3cc051d28d4bb5fdd04f68455dfb2f /package/mac80211/patches/002-disable_rfkill.patch
parent82c740f5ef4ed38b9b69fb09924c6f27700640ab (diff)
downloadmaster-187ad058-b8f56104dc472be555ad2b83f92c1e210eb61a5f.tar.gz
master-187ad058-b8f56104dc472be555ad2b83f92c1e210eb61a5f.tar.bz2
master-187ad058-b8f56104dc472be555ad2b83f92c1e210eb61a5f.zip
package/mac80211: Add linux 3.0 compatibility
Add patches from Hauke adding linux 3.0 compatibility. Signed-off-by: Jonas Gorski <jonas.gorski+openwrt@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27187 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/mac80211/patches/002-disable_rfkill.patch')
-rw-r--r--package/mac80211/patches/002-disable_rfkill.patch8
1 files changed, 4 insertions, 4 deletions
diff --git a/package/mac80211/patches/002-disable_rfkill.patch b/package/mac80211/patches/002-disable_rfkill.patch
index f6350a6ba4..a894028d4b 100644
--- a/package/mac80211/patches/002-disable_rfkill.patch
+++ b/package/mac80211/patches/002-disable_rfkill.patch
@@ -1,6 +1,6 @@
--- a/config.mk
+++ b/config.mk
-@@ -74,7 +74,7 @@ endif # build check
+@@ -87,7 +87,7 @@ endif # build check
endif # kernel Makefile check
# These both are needed by compat-wireless || compat-bluetooth so enable them
@@ -9,10 +9,10 @@
ifeq ($(CONFIG_MAC80211),y)
$(error "ERROR: you have MAC80211 compiled into the kernel, CONFIG_MAC80211=y, as such you cannot replace its mac80211 driver. You need this set to CONFIG_MAC80211=m. If you are using Fedora upgrade your kernel as later version should this set as modular. For further information on Fedora see https://bugzilla.redhat.com/show_bug.cgi?id=470143. If you are using your own kernel recompile it and make mac80211 modular")
-@@ -622,10 +622,10 @@ endif #CONFIG_COMPAT_KERNEL_27
+@@ -635,10 +635,10 @@ endif #CONFIG_COMPAT_KERNEL_2_6_27
# We need the backported rfkill module on kernel < 2.6.31.
# In more recent kernel versions use the in kernel rfkill module.
- ifdef CONFIG_COMPAT_KERNEL_31
+ ifdef CONFIG_COMPAT_KERNEL_2_6_31
-CONFIG_RFKILL_BACKPORT=m
+# CONFIG_RFKILL_BACKPORT=m
ifdef CONFIG_LEDS_TRIGGERS
@@ -21,7 +21,7 @@
endif #CONFIG_LEDS_TRIGGERS
-CONFIG_RFKILL_BACKPORT_INPUT=y
+# CONFIG_RFKILL_BACKPORT_INPUT=y
- endif #CONFIG_COMPAT_KERNEL_31
+ endif #CONFIG_COMPAT_KERNEL_2_6_31
--- a/include/linux/rfkill.h
+++ b/include/linux/rfkill.h