aboutsummaryrefslogtreecommitdiffstats
path: root/package/ltq-dsl/src/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2011-10-10 15:14:17 +0000
committerJohn Crispin <blogic@openwrt.org>2011-10-10 15:14:17 +0000
commitd504175233010ec8b3431ca3f18c7d3760ee4993 (patch)
treec744550c4eb70b0a99eeee97ad19b8f914d40fdc /package/ltq-dsl/src/Makefile
parent4cc422e0f3860fbe49957352cfb7cd61e5e884d3 (diff)
downloadmaster-187ad058-d504175233010ec8b3431ca3f18c7d3760ee4993.tar.gz
master-187ad058-d504175233010ec8b3431ca3f18c7d3760ee4993.tar.bz2
master-187ad058-d504175233010ec8b3431ca3f18c7d3760ee4993.zip
[ltq-dsl]
* add support for ar9 * add support for ase (vr9 support is still a todo) git-svn-id: svn://svn.openwrt.org/openwrt/trunk@28406 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/ltq-dsl/src/Makefile')
-rw-r--r--package/ltq-dsl/src/Makefile18
1 files changed, 17 insertions, 1 deletions
diff --git a/package/ltq-dsl/src/Makefile b/package/ltq-dsl/src/Makefile
index 89c4e712d7..a923170981 100644
--- a/package/ltq-dsl/src/Makefile
+++ b/package/ltq-dsl/src/Makefile
@@ -1,3 +1,19 @@
obj-m = lantiq_mei.o lantiq_atm.o
+lantiq_atm-objs := ifxmips_atm_core.o
-lantiq_atm-objs := ifxmips_atm_core.o ifxmips_atm_danube.o
+ifeq ($(BUILD_VARIANT),danube)
+ EXTRA_CFLAGS+=-DCONFIG_DANUBE
+ lantiq_atm-objs += ifxmips_atm_danube.o
+endif
+ifeq ($(BUILD_VARIANT),ase)
+ EXTRA_CFLAGS+=-DCONFIG_AMAZON_SE
+ lantiq_atm-objs += ifxmips_atm_amazon_se.o
+endif
+ifeq ($(BUILD_VARIANT),ar9)
+ EXTRA_CFLAGS+=-DCONFIG_AR9
+ lantiq_atm-objs += ifxmips_atm_ar9.o
+endif
+ifeq ($(BUILD_VARIANT),vr9)
+ EXTRA_CFLAGS+=-DCONFIG_VR9
+ lantiq_atm-objs += ifxmips_atm_vr9.o
+endif