aboutsummaryrefslogtreecommitdiffstats
path: root/package/linux-atm
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-11-23 00:29:07 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-11-23 00:29:07 +0000
commit5a325930579db5f9175bea19459c845746801ae4 (patch)
tree8b63e203323c3c4ab05aa9bf0a9ec17f5dc87c91 /package/linux-atm
parent7bc567a0409f4d9aa9a4e12e9c56bc892b737da3 (diff)
downloadmaster-187ad058-5a325930579db5f9175bea19459c845746801ae4.tar.gz
master-187ad058-5a325930579db5f9175bea19459c845746801ae4.tar.bz2
master-187ad058-5a325930579db5f9175bea19459c845746801ae4.zip
replace lots of manual install commands with INSTALL_* variables
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5624 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/linux-atm')
-rw-r--r--package/linux-atm/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/package/linux-atm/Makefile b/package/linux-atm/Makefile
index ced3da69ef..9aae0a0b0e 100644
--- a/package/linux-atm/Makefile
+++ b/package/linux-atm/Makefile
@@ -73,15 +73,15 @@ define Build/UninstallDev
endef
define Package/linux-atm/install
- install -d -m0755 $(1)/usr/lib
+ $(INSTALL_DIR) $(1)/usr/lib
cp -f $(PKG_INSTALL_DIR)/usr/lib/libatm.so.1 $(1)/usr/lib
endef
define Package/br2684ctl/install
- install -d -m0755 $(1)/usr/sbin
+ $(INSTALL_DIR) $(1)/usr/sbin
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/br2684ctl $(1)/usr/sbin/
- install -d -m0755 $(1)/etc/hotplug.d/net
- install -m0644 ./files/br2684.hotplug $(1)/etc/hotplug.d/net/30-br2684
+ $(INSTALL_DIR) $(1)/etc/hotplug.d/net
+ $(INSTALL_DATA) ./files/br2684.hotplug $(1)/etc/hotplug.d/net/30-br2684
endef
$(eval $(call BuildPackage,linux-atm))