aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/uclibc++/Makefile
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2015-06-19 14:36:37 +0000
committerSteven Barth <steven@midlink.org>2015-06-19 14:36:37 +0000
commit00e84ffb67163cd49c97e198849ce2af4d4ed9d1 (patch)
tree4290ad9599c79d870a60cf6c4f4d52be80810c85 /package/libs/uclibc++/Makefile
parentf79ef233edcbf985463495d10990c1c1e374ff92 (diff)
downloadmaster-187ad058-00e84ffb67163cd49c97e198849ce2af4d4ed9d1.tar.gz
master-187ad058-00e84ffb67163cd49c97e198849ce2af4d4ed9d1.tar.bz2
master-187ad058-00e84ffb67163cd49c97e198849ce2af4d4ed9d1.zip
uclibc++: only disable SSP for ppc
Signed-off-by: Steven Barth <steven@midlink.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46067 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/libs/uclibc++/Makefile')
-rw-r--r--package/libs/uclibc++/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/libs/uclibc++/Makefile b/package/libs/uclibc++/Makefile
index a726a1edad..8374db5322 100644
--- a/package/libs/uclibc++/Makefile
+++ b/package/libs/uclibc++/Makefile
@@ -44,7 +44,11 @@ UCLIBC_TARGET_ARCH:=$(shell echo $(ARCH) | sed -e s'/-.*//' \
-e 's/mipsel.*/mips/' \
)
-TARGET_CFLAGS += $(FPIC) -fno-stack-protector
+ifeq ($(ARCH),powerpc)
+TARGET_CFLAGS += -fno-stack-protector
+endif
+
+TARGET_CFLAGS += $(FPIC)
ifneq ($(CONFIG_CCACHE),)
TARGET_CXX=$(TARGET_CXX_NOCACHE)