aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/toolchain
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-03-20 13:51:47 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-03-20 13:51:47 +0000
commitffbd5fc511ee6f46cd047d41e990d25a286923be (patch)
tree84dcff766727ec1a31c0a14241265ee0eb6a49dc /package/libs/toolchain
parent9985a730766608d45b6f40e2da755605bbb28f64 (diff)
downloadmaster-187ad058-ffbd5fc511ee6f46cd047d41e990d25a286923be.tar.gz
master-187ad058-ffbd5fc511ee6f46cd047d41e990d25a286923be.tar.bz2
master-187ad058-ffbd5fc511ee6f46cd047d41e990d25a286923be.zip
toolchain: add a symlink for musl softfloat ldso to the path where our gcc expects it
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39966 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/libs/toolchain')
-rw-r--r--package/libs/toolchain/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/libs/toolchain/Makefile b/package/libs/toolchain/Makefile
index 202e9d095d..a29b3221ec 100644
--- a/package/libs/toolchain/Makefile
+++ b/package/libs/toolchain/Makefile
@@ -428,6 +428,9 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
$(1)/lib/
endef
+ LD_MUSL_NAME = $(notdir $(firstword $(wildcard $(TOOLCHAIN_DIR)/lib/ld-musl-*.so*)))
+ $(warning LD_MUSL_NAME='$(LD_MUSL_NAME)')
+
define Package/musl/install
$(INSTALL_DIR) $(1)/lib
$(CP) \
@@ -436,6 +439,7 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
$(CP) \
$(TOOLCHAIN_DIR)/lib/libc.so* \
$(1)/lib/
+ $(if $(findstring -sf.so,$(LD_MUSL_NAME)),ln -s $(LD_MUSL_NAME) $(1)/lib/$(subst -sf.so,.so,$(LD_MUSL_NAME)))
endef
define Package/libc/install