aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/toolchain
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2014-11-19 12:17:34 +0000
committerJonas Gorski <jogo@openwrt.org>2014-11-19 12:17:34 +0000
commitb5ff15f7054199ca4d973115743b5f5392feb2dc (patch)
tree78f5f4a9467e4a37875fe1dc4c52c7889089f697 /package/libs/toolchain
parent41436967c385df182a7ce8df9c310f977161def5 (diff)
downloadmaster-187ad058-b5ff15f7054199ca4d973115743b5f5392feb2dc.tar.gz
master-187ad058-b5ff15f7054199ca4d973115743b5f5392feb2dc.tar.bz2
master-187ad058-b5ff15f7054199ca4d973115743b5f5392feb2dc.zip
toolchain: musl: fix symlink for ldd
ld-musl-*.so* is a symlink "broken" for the hostsystem, so wildcard will skip it, causing LD_MUSL_NAME to empty and the ldd symlink pointing to ../../lib directly. This causes sysupgrade failing to copy any linked libaries and consequently failing to run anything after switching to ram disk. Fix this by creating a symlink directly pointing to where ld-musl-*.so* points to. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43314 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/libs/toolchain')
-rw-r--r--package/libs/toolchain/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/libs/toolchain/Makefile b/package/libs/toolchain/Makefile
index 1cb83fa126..10c990a126 100644
--- a/package/libs/toolchain/Makefile
+++ b/package/libs/toolchain/Makefile
@@ -466,7 +466,7 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
$(1)/lib/
endef
- LD_MUSL_NAME = $(notdir $(firstword $(wildcard $(TOOLCHAIN_DIR)/lib/ld-musl-*.so*)))
+ LD_MUSL_NAME = $(notdir $(firstword $(wildcard $(TOOLCHAIN_DIR)/lib/libc.so*)))
define Package/musl/install
$(INSTALL_DIR) $(1)/lib $(1)/usr/bin