aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/libusb-compat/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-06-04 07:20:02 +0000
committerJohn Crispin <blogic@openwrt.org>2014-06-04 07:20:02 +0000
commit6e8d82998b4131972ae2d63cd64aae91f3f4c686 (patch)
tree52377d09f5577fc2418df00671aa665d2c960af9 /package/libs/libusb-compat/Makefile
parent8d9f6f3396da4e546cf6990a2230469d0bab7339 (diff)
downloadmaster-187ad058-6e8d82998b4131972ae2d63cd64aae91f3f4c686.tar.gz
master-187ad058-6e8d82998b4131972ae2d63cd64aae91f3f4c686.tar.bz2
master-187ad058-6e8d82998b4131972ae2d63cd64aae91f3f4c686.zip
libusb-compat: create directory for libusb-config
Fix a build regression caused by r39975 by making sure $(STAGING_DIR)/host directory exists before trying to copy files to it. Cc: Florian Fainelli <florian@openwrt.org> Signed-off-by: Tim Harvey <tharvey@gateworks.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40998 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/libs/libusb-compat/Makefile')
-rw-r--r--package/libs/libusb-compat/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/libs/libusb-compat/Makefile b/package/libs/libusb-compat/Makefile
index 3b770837da..a67d0c0f21 100644
--- a/package/libs/libusb-compat/Makefile
+++ b/package/libs/libusb-compat/Makefile
@@ -38,6 +38,8 @@ endef
TARGET_CFLAGS += $(FPIC)
define Build/InstallDev
+ $(INSTALL_DIR) $(STAGING_DIR)/host/bin
+
$(CP) $(PKG_INSTALL_DIR)/* $(1)/
$(CP) $(PKG_INSTALL_DIR)/usr/bin/libusb-config $(STAGING_DIR)/host/bin
endef