aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/cyassl/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2013-10-29 09:53:48 +0000
committerJo-Philipp Wich <jow@openwrt.org>2013-10-29 09:53:48 +0000
commit407cc7b92812086648c7e613fc237c91498b743b (patch)
tree95f8dfefde2b4b52490e8d0191120f2551084e2e /package/libs/cyassl/Makefile
parent080506d57069f0239cd370ba9036ea948a6c17e1 (diff)
downloadmaster-187ad058-407cc7b92812086648c7e613fc237c91498b743b.tar.gz
master-187ad058-407cc7b92812086648c7e613fc237c91498b743b.tar.bz2
master-187ad058-407cc7b92812086648c7e613fc237c91498b743b.zip
Revert "[cyassl]: upgrade to 2.8.0"
Reverts the CyaSSL version bump for now since the update completely broke trunk building due to incompatible changes in the IO callback API which in turn breaks the core ustream-ssl package. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38576 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/libs/cyassl/Makefile')
-rw-r--r--package/libs/cyassl/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/package/libs/cyassl/Makefile b/package/libs/cyassl/Makefile
index df8335e800..063e572166 100644
--- a/package/libs/cyassl/Makefile
+++ b/package/libs/cyassl/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2013 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=cyassl
-PKG_VERSION:=2.8.0
-PKG_RELEASE:=1
+PKG_VERSION:=1.6.5
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).zip
PKG_SOURCE_URL:=http://www.yassl.com/
-PKG_MD5SUM:=7465d4815af90eff01095fa1b031ce09
+PKG_MD5SUM:=98c2c6350acf1d089756a1de9ccb9903
PKG_FIXUP:=patch-libtool
PKG_INSTALL:=1
@@ -38,15 +38,14 @@ TARGET_CFLAGS += $(FPIC)
CONFIGURE_ARGS += \
--without-zlib \
- --enable-singlethreaded \
- --disable-examples
+ --enable-singleThreaded
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
$(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libcyassl.{so*,la} $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libcyassl.{a,so*,la} $(1)/usr/lib/
endef
define Package/libcyassl/install