aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-07-19 12:22:26 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-07-19 12:22:26 +0000
commitf757b59758e39991ad08652b5ff443d71b4928cc (patch)
tree8de7b87ac5f809337f475315f7b7a378839f8496 /package/kernel
parent22a6e86ac360020b2e61acdda6f39de01c7066e4 (diff)
downloadmaster-187ad058-f757b59758e39991ad08652b5ff443d71b4928cc.tar.gz
master-187ad058-f757b59758e39991ad08652b5ff443d71b4928cc.tar.bz2
master-187ad058-f757b59758e39991ad08652b5ff443d71b4928cc.zip
[package] kernel/modules: package I2C bus driver for PPC4xx based systems
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16919 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/i2c.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/modules/i2c.mk b/package/kernel/modules/i2c.mk
index 444cc874f5..67713f300d 100644
--- a/package/kernel/modules/i2c.mk
+++ b/package/kernel/modules/i2c.mk
@@ -126,3 +126,19 @@ endef
$(eval $(call KernelPackage,i2c-scx200-acb))
+define KernelPackage/i2c-ibm-iic
+ SUBMENU:=$(I2C_MENU)
+ TITLE:=IBM PPC 4xx on-chip I2C interface support
+ DEPENDS:=@TARGET_ppc40x||TARGET_ppc4xx +kmod-i2c-core
+ KCONFIG:=CONFIG_I2C_IBM_IIC
+ FILES:=$(LINUX_DIR)/drivers/i2c/busses/i2c-ibm_iic.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,59,i2c-ibm_iic)
+endef
+
+define KernelPackage/i2c-ibm-iic/description
+ Kernel module for IIC peripheral found on embedded IBM PPC4xx based systems.
+endef
+
+$(eval $(call KernelPackage,i2c-ibm-iic))
+
+