aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-09-15 03:48:20 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-09-15 03:48:20 +0000
commitb97629f51b14dc8abdadf8d1d52ff1393e72c3e8 (patch)
treee2da66f3f1932946712ef97454cbf261e2373c4e /package/kernel
parent2c99d87747570decc1ba15ce18e03b839e7c7d5a (diff)
downloadmaster-187ad058-b97629f51b14dc8abdadf8d1d52ff1393e72c3e8.tar.gz
master-187ad058-b97629f51b14dc8abdadf8d1d52ff1393e72c3e8.tar.bz2
master-187ad058-b97629f51b14dc8abdadf8d1d52ff1393e72c3e8.zip
[PATCH] Support for RTL-8139C+ ethernet adapters
Signed-off-by: Nathan Williams <nathan@traverse.com.au> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23068 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/netdevices.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/modules/netdevices.mk b/package/kernel/modules/netdevices.mk
index c3f8d1ff38..69ec517adb 100644
--- a/package/kernel/modules/netdevices.mk
+++ b/package/kernel/modules/netdevices.mk
@@ -205,6 +205,22 @@ endef
$(eval $(call KernelPackage,8139too))
+define KernelPackage/8139cp
+ SUBMENU:=$(NETWORK_DEVICES_MENU)
+ TITLE:=RealTek RTL-8139C+ PCI Fast Ethernet Adapter kernel support
+ DEPENDS:=@TARGET_x86
+ KCONFIG:=CONFIG_8139CP
+ FILES:=$(LINUX_DIR)/drivers/net/8139cp.ko
+ AUTOLOAD:=$(call AutoLoad,50,8139cp)
+endef
+
+define KernelPackage/8139cp/description
+ Kernel module for RealTek RTL-8139C+ PCI Fast Ethernet adapters.
+endef
+
+$(eval $(call KernelPackage,8139cp))
+
+
define KernelPackage/r8169
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=RealTek RTL-8169 PCI Gigabit Ethernet Adapter kernel support