aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2013-07-14 14:23:04 +0000
committerHauke Mehrtens <hauke@openwrt.org>2013-07-14 14:23:04 +0000
commita2013d3f7c1c2020d95a8399ce20bd5c487ba854 (patch)
tree7bdd07639248a9c44c0aa77ed4955f22c1e8dc63 /package/kernel
parentc57d29f9774308971662c3fb23861ae4767df12c (diff)
downloadmaster-187ad058-a2013d3f7c1c2020d95a8399ce20bd5c487ba854.tar.gz
master-187ad058-a2013d3f7c1c2020d95a8399ce20bd5c487ba854.tar.bz2
master-187ad058-a2013d3f7c1c2020d95a8399ce20bd5c487ba854.zip
mac80211: b43: load b43 on core rev 17 and 18.
This is now controlled by a module parameter and the default configuration depends on brcmsmac being installed. This patch causes b43 to take core rev 17 and 18 always by default. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37307 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/mac80211/Makefile2
-rw-r--r--package/kernel/mac80211/patches/847-b43-always-take-overlapping-devs.patch11
2 files changed, 12 insertions, 1 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index 2f7fbbe877..e4fa9252f1 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -1221,7 +1221,7 @@ endif
config-$(call config_package,carl9170) += CARL9170
config-$(call config_package,b43) += B43
-config-y += B43_SSB B43_BCMA B43_BCMA_EXTRA B43_PHY_LP
+config-y += B43_SSB B43_BCMA B43_PHY_LP
config-$(CONFIG_PACKAGE_B43_PHY_N) += B43_PHY_N
config-$(CONFIG_PACKAGE_B43_PHY_HT) += B43_PHY_HT
config-$(CONFIG_PACKAGE_B43_PIO) += B43_PIO
diff --git a/package/kernel/mac80211/patches/847-b43-always-take-overlapping-devs.patch b/package/kernel/mac80211/patches/847-b43-always-take-overlapping-devs.patch
new file mode 100644
index 0000000000..9d1d419460
--- /dev/null
+++ b/package/kernel/mac80211/patches/847-b43-always-take-overlapping-devs.patch
@@ -0,0 +1,11 @@
+--- a/drivers/net/wireless/b43/main.c
++++ b/drivers/net/wireless/b43/main.c
+@@ -118,7 +118,7 @@ static int b43_modparam_pio = 0;
+ module_param_named(pio, b43_modparam_pio, int, 0644);
+ MODULE_PARM_DESC(pio, "Use PIO accesses by default: 0=DMA, 1=PIO");
+
+-static int modparam_allhwsupport = !IS_ENABLED(CPTCFG_BRCMSMAC);
++static int modparam_allhwsupport = 1;
+ module_param_named(allhwsupport, modparam_allhwsupport, int, 0444);
+ MODULE_PARM_DESC(allhwsupport, "Enable support for all hardware (even it if overlaps with the brcmsmac driver)");
+