aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2015-09-11 20:37:23 +0000
committerHauke Mehrtens <hauke@openwrt.org>2015-09-11 20:37:23 +0000
commit97faf98bce2dabb2d67501ba0771e814730fc998 (patch)
treec3f1d69e79e055cb6ba6caba3940d7dec63e9426 /package/kernel
parent92d13b10dab8b6724e6b04a3a767a8015f6f652a (diff)
downloadmaster-187ad058-97faf98bce2dabb2d67501ba0771e814730fc998.tar.gz
master-187ad058-97faf98bce2dabb2d67501ba0771e814730fc998.tar.bz2
master-187ad058-97faf98bce2dabb2d67501ba0771e814730fc998.zip
mac80211: add iwlagn debug options
Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46886 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/mac80211/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index 512c9598cd..e4299b2ab1 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -859,6 +859,40 @@ endef
define KernelPackage/iwlagn/config
if PACKAGE_kmod-iwlagn
+ config PACKAGE_IWLWIFI_DEBUG
+ bool "Enable full debugging output in the iwlagn driver"
+ default n
+ help
+ This option will enable debug tracing output for the iwlwifi drivers
+
+ This will result in the kernel module being ~100k larger. You can
+ control which debug output is sent to the kernel log by setting the
+ value in
+
+ /sys/module/iwlwifi/parameters/debug
+
+ This entry will only exist if this option is enabled.
+
+ To set a value, simply echo an 8-byte hex value to the same file:
+
+ % echo 0x43fff > /sys/module/iwlwifi/parameters/debug
+
+ You can find the list of debug mask values in:
+ drivers/net/wireless/iwlwifi/iwl-debug.h
+
+ If this is your first time using this driver, you should say Y here
+ as the debug information can assist others in helping you resolve
+ any problems you may encounter.
+
+ config PACKAGE_IWLWIFI_DEBUGFS
+ bool "iwlwifi debugfs support"
+ depends on PACKAGE_MAC80211_DEBUGFS
+ default n
+ help
+ Enable creation of debugfs files for the iwlwifi drivers. This
+ is a low-impact option that allows getting insight into the
+ driver's state at runtime.
+
config IWL100_FW
bool "Intel 100 Firmware"
default y
@@ -1667,6 +1701,8 @@ config-$(call config_package,iwl-legacy) += IWLEGACY
config-$(call config_package,iwl3945) += IWL3945
config-$(call config_package,iwl4965) += IWL4965
config-$(call config_package,iwlagn) += IWLWIFI IWLDVM IWLMVM
+config-$(CONFIG_PACKAGE_IWLWIFI_DEBUG)+= IWLWIFI_DEBUG
+config-$(CONFIG_PACKAGE_IWLWIFI_DEBUGFS)+= IWLWIFI_DEBUGFS
config-$(call config_package,net-libipw) += LIBIPW
config-$(call config_package,net-ipw2100) += IPW2100