aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2011-02-20 17:24:20 +0000
committerFlorian Fainelli <florian@openwrt.org>2011-02-20 17:24:20 +0000
commit8acdb298b220c8da677494939de3d8a7ef1135f0 (patch)
treeabdfc4378267aa0983dc65723bb42c8c1c929252 /package/kernel
parentd83ab218fe6799c8f6f9c4b0ff0e05044ed26185 (diff)
downloadmaster-187ad058-8acdb298b220c8da677494939de3d8a7ef1135f0.tar.gz
master-187ad058-8acdb298b220c8da677494939de3d8a7ef1135f0.tar.bz2
master-187ad058-8acdb298b220c8da677494939de3d8a7ef1135f0.zip
[package] add Marvell orion watchdog timer module
This patch adds kernelmodule for watchdog timer on platform orion. Signed-off-by: Michael Kämmerer <mrk_at_h3c_._de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25620 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/other.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index f6e6ea3990..56cda45f70 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -770,6 +770,22 @@ endef
$(eval $(call KernelPackage,wdt-omap))
+define KernelPackage/wdt-orion
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Marvell Orion Watchdog timer
+ DEPENDS:=@TARGET_orion
+ KCONFIG:=CONFIG_ORION_WATCHDOG
+ FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/orion_wdt.ko
+ AUTOLOAD:=$(call AutoLoad,50,orion_wdt)
+endef
+
+define KernelPackage/wdt-orion/description
+ Kernel module for Marvell orion watchdog timer.
+endef
+
+$(eval $(call KernelPackage,wdt-orion))
+
+
define KernelPackage/wdt-sc520
SUBMENU:=$(OTHER_MENU)
TITLE:=Natsemi SC520 Watchdog support