aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorClaudio Mignanti <c.mignanti@gmail.com>2010-07-12 13:20:01 +0000
committerClaudio Mignanti <c.mignanti@gmail.com>2010-07-12 13:20:01 +0000
commit8054d2a95841f1e07d564bf7908aea539b7cd17e (patch)
treea3dfa176d96112bd4f86f045e9665ea9f30c8066 /package/kernel
parentf89d76bff4941a1c47fa40d2b8f1cf7441568ae1 (diff)
downloadmaster-187ad058-8054d2a95841f1e07d564bf7908aea539b7cd17e.tar.gz
master-187ad058-8054d2a95841f1e07d564bf7908aea539b7cd17e.tar.bz2
master-187ad058-8054d2a95841f1e07d564bf7908aea539b7cd17e.zip
[kernel] Add package for gpio-pwm
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22143 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/other.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 071645984b..9b8259b3df 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -661,3 +661,19 @@ define KernelPackage/wdt-scx200/description
endef
$(eval $(call KernelPackage,wdt-scx200))
+
+
+define KernelPackage/pwm-gpio
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=PWM over GPIO
+ KCONFIG:=CONFIG_GENERIC_PWM \
+ CONFIG_GPIO_PWM
+ FILES:=$(LINUX_DIR)/drivers/pwm/gpio-pwm.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,51,gpio-pwm)
+endef
+
+define KernelPackage/pwm-gpio/description
+ Kernel module to models a single-channel PWM device using a timer and a GPIO pin
+endef
+
+$(eval $(call KernelPackage,pwm-gpio))