aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-12-23 11:43:18 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-12-23 11:43:18 +0000
commit77a5ca00b3adc04becb5cfa3eb6f1754cdb1d371 (patch)
tree505d86c3833fe56d087d20f907c897389466d2bd /package/kernel
parentb7434c9e06443bd8764829b7e3dd49eef7de7e35 (diff)
downloadmaster-187ad058-77a5ca00b3adc04becb5cfa3eb6f1754cdb1d371.tar.gz
master-187ad058-77a5ca00b3adc04becb5cfa3eb6f1754cdb1d371.tar.bz2
master-187ad058-77a5ca00b3adc04becb5cfa3eb6f1754cdb1d371.zip
kernel: make kmod-thermal dependency conditional to match upstream kernel module configuration dependency for hwmon-pwmfan
Signed-off-by: Sebastian Careba <nitroshift@yahoo.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47968 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/hwmon.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/hwmon.mk b/package/kernel/linux/modules/hwmon.mk
index e09efa17c0..93d7a775a9 100644
--- a/package/kernel/linux/modules/hwmon.mk
+++ b/package/kernel/linux/modules/hwmon.mk
@@ -289,7 +289,7 @@ define KernelPackage/hwmon-pwmfan
KCONFIG:=CONFIG_SENSORS_PWM_FAN
FILES:=$(LINUX_DIR)/drivers/hwmon/pwm-fan.ko
AUTOLOAD:=$(call AutoLoad,60,pwm-fan)
- $(call AddDepends/hwmon,)
+ $(call AddDepends/hwmon, +PACKAGE_kmod-thermal:kmod-thermal)
endef
define KernelPackage/hwmon-pwmfan/description