aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-01-14 17:03:45 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-01-14 17:03:45 +0000
commit13a86376763bf760c0df2b97c95a63b0671c5790 (patch)
treef1599b950d59e39dcee65133684b5ba00b59ff66 /package/kernel
parentbf21e3818de87acd016e163cb880030fce03cff3 (diff)
downloadmaster-187ad058-13a86376763bf760c0df2b97c95a63b0671c5790.tar.gz
master-187ad058-13a86376763bf760c0df2b97c95a63b0671c5790.tar.bz2
master-187ad058-13a86376763bf760c0df2b97c95a63b0671c5790.zip
kernel: avoid recursive dependency caused by kmod-i2c-mv64xxx
Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35157 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/i2c.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/kernel/modules/i2c.mk b/package/kernel/modules/i2c.mk
index df34bbf835..e1adafdb0c 100644
--- a/package/kernel/modules/i2c.mk
+++ b/package/kernel/modules/i2c.mk
@@ -154,7 +154,8 @@ I2C_MV64XXX_MODULES:=\
define KernelPackage/i2c-mv64xxx
$(call i2c_defaults,$(I2C_MV64XXX_MODULES),59)
TITLE:=Orion Platform I2C interface support
- DEPENDS:=@TARGET_kirkwood||TARGET_orion||TARGET_mvebu +kmod-i2c-core TARGET_mvebu:kmod-of-i2c
+ DEPENDS:=@TARGET_kirkwood||TARGET_orion||TARGET_mvebu (TARGET_kirkwood||TARGET_orion):kmod-i2c-core \
+ TARGET_mvebu:kmod-of-i2c
endef
define KernelPackage/i2c-mv64xxx/description