aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules/wireless.mk
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2007-09-26 02:49:50 +0000
committerNicolas Thill <nico@openwrt.org>2007-09-26 02:49:50 +0000
commitfc4a2e8ad9389afc570ceb68c6fe76f1aedbf81b (patch)
tree4adf2d55f5c93af585b0c4e4806752af3685eedc /package/kernel/modules/wireless.mk
parent17a1be5e2c212d2042d9441a498f1c1b70443e97 (diff)
downloadmaster-187ad058-fc4a2e8ad9389afc570ceb68c6fe76f1aedbf81b.tar.gz
master-187ad058-fc4a2e8ad9389afc570ceb68c6fe76f1aedbf81b.tar.bz2
master-187ad058-fc4a2e8ad9389afc570ceb68c6fe76f1aedbf81b.zip
fix kmod-hostap build on 2.4, add kmod-hostap-cs (closes: #1957)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9030 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/modules/wireless.mk')
-rw-r--r--package/kernel/modules/wireless.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/kernel/modules/wireless.mk b/package/kernel/modules/wireless.mk
index a9ec1f5de8..6887a491a3 100644
--- a/package/kernel/modules/wireless.mk
+++ b/package/kernel/modules/wireless.mk
@@ -8,10 +8,12 @@
WIRELESS_MENU:=Wireless Drivers
+# NOTE: dependency on 2.6 was removed since it was inherited by kmod-hostap
+# and prevented it from even showing up in menuconfig on 2.4
define KernelPackage/ieee80211
SUBMENU:=$(WIRELESS_MENU)
TITLE:=802.11 Networking stack
- DEPENDS:=@LINUX_2_6 +kmod-crypto-arc4 +kmod-crypto-aes +kmod-crypto-michael-mic
+ DEPENDS:=+kmod-crypto-arc4 +kmod-crypto-aes +kmod-crypto-michael-mic
KCONFIG:= \
CONFIG_IEEE80211 \
CONFIG_IEEE80211_CRYPT_WEP \