aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules/other.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2008-11-15 11:26:23 +0000
committerFlorian Fainelli <florian@openwrt.org>2008-11-15 11:26:23 +0000
commit67df4eb0fff6dc72c0fc06b5006e8d44bc6f140e (patch)
treebe22dc8cc8a5849a2399347906ae9fc98b1834a0 /package/kernel/modules/other.mk
parent2fc763d2487c50cb173df301078c2eafd16f53ad (diff)
downloadmaster-187ad058-67df4eb0fff6dc72c0fc06b5006e8d44bc6f140e.tar.gz
master-187ad058-67df4eb0fff6dc72c0fc06b5006e8d44bc6f140e.tar.bz2
master-187ad058-67df4eb0fff6dc72c0fc06b5006e8d44bc6f140e.zip
Package bcm63xx-pcmcia kernel module and fix compilation
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13212 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/modules/other.mk')
-rw-r--r--package/kernel/modules/other.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index f82dfdef90..eacf970df3 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -140,6 +140,20 @@ endef
$(eval $(call KernelPackage,pcmcia-core))
+define KernelPackage/pcmcia-bcm63xx
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Broadcom BCM63xx PCMCIA support
+ DEPENDS:=kmod-pcmcia-core @TARGET_brcm63xx
+ KCONFIG:=CONFIG_PCMCIA_BCM63XX
+ FILES:=$(LINUX_DIR)/drivers/pcmcia/bcm63xx_pcmcia.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,41,bcm63xx_pcmcia)
+endef
+
+define KernelPackage/pcmcia-bcm63xx/description
+ Kernel support for PCMCIA/CardBus controller on the BCM63xx SoC
+endef
+
+$(eval $(call KernelPackage,pcmcia-bcm63xx))
define KernelPackage/pcmcia-serial
SUBMENU:=$(OTHER_MENU)