aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules/netdevices.mk
diff options
context:
space:
mode:
authorVasilis Tsiligiannis <b_tsiligiannis@silverton.gr>2011-04-07 23:31:56 +0000
committerVasilis Tsiligiannis <b_tsiligiannis@silverton.gr>2011-04-07 23:31:56 +0000
commit1558f59c5d57abc2e2319fff5ec54f9a7d6ccc5b (patch)
tree6ef55436ce10b95492da6a786535e9b895486036 /package/kernel/modules/netdevices.mk
parenta1052d016bc4b1ae3f90c792bde2a23bea64bd70 (diff)
downloadmaster-187ad058-1558f59c5d57abc2e2319fff5ec54f9a7d6ccc5b.tar.gz
master-187ad058-1558f59c5d57abc2e2319fff5ec54f9a7d6ccc5b.tar.bz2
master-187ad058-1558f59c5d57abc2e2319fff5ec54f9a7d6ccc5b.zip
[package] kernel/modules: Enable Realtek R8169 not only for x86
This enables support for Realtek 8169 based network cards for other platforms than x86. I have a mini-PCI card on ixp4xxx running here. Maybe for the other cards in netdevices.mk a @DEPENDS change from @TARGET_x86 to @PCI_SUPPORT makes also sense. Signed-off-by: Christoph König <christoph.koenig@ikt.uni-hannover.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26529 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/modules/netdevices.mk')
-rw-r--r--package/kernel/modules/netdevices.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/modules/netdevices.mk b/package/kernel/modules/netdevices.mk
index e8036f0e00..762a171773 100644
--- a/package/kernel/modules/netdevices.mk
+++ b/package/kernel/modules/netdevices.mk
@@ -224,7 +224,7 @@ $(eval $(call KernelPackage,8139cp))
define KernelPackage/r8169
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=RealTek RTL-8169 PCI Gigabit Ethernet Adapter kernel support
- DEPENDS:=@TARGET_x86
+ DEPENDS:=@PCI_SUPPORT
KCONFIG:=CONFIG_R8169 \
CONFIG_R8169_NAPI=y \
CONFIG_R8169_VLAN=n