aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules/crypto.mk
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-05-09 06:16:56 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-05-09 06:16:56 +0000
commit1eaa138aa9d720b92cb60e7ac427159611ea2a9f (patch)
tree0c3613f67853656f918e1ed88ac1fe4806775ca1 /package/kernel/modules/crypto.mk
parenta69e73af4acb7a4ac96d843e7b90dcccdc7a8191 (diff)
downloadmaster-187ad058-1eaa138aa9d720b92cb60e7ac427159611ea2a9f.tar.gz
master-187ad058-1eaa138aa9d720b92cb60e7ac427159611ea2a9f.tar.bz2
master-187ad058-1eaa138aa9d720b92cb60e7ac427159611ea2a9f.zip
[package] kernel/modules: build pcompress.ko for kernel >=2.6.30
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15737 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/modules/crypto.mk')
-rw-r--r--package/kernel/modules/crypto.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/package/kernel/modules/crypto.mk b/package/kernel/modules/crypto.mk
index 78a8a19fbf..68c1a95cfe 100644
--- a/package/kernel/modules/crypto.mk
+++ b/package/kernel/modules/crypto.mk
@@ -28,11 +28,14 @@ endif
ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.26)),1)
SHA512_SUFFIX:=$(CRYPTO_GENERIC)
endif
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.30)),1)
+ CRYPTO_MODULE_PCOMPRESS:=PCOMPRESS=pcompress
+endif
CRYPTO_MODULES = \
ALGAPI=crypto_algapi \
AEAD=aead \
- $(if $(LINUX_2_6_30),PCOMPRESS=pcompress) \
+ $(CRYPTO_MODULE_PCOMPRESS) \
BLKCIPHER=$(BLKCIPHER_PREFIX)blkcipher \
HASH=crypto_hash \
MANAGER=cryptomgr \