aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules/block.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-11-29 00:33:32 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-11-29 00:33:32 +0000
commitf6c457dbde39d676a20f4caf34ae5293c5361574 (patch)
treeee74b5ed75d686ed7bdf8d6165d7aefc79a9a4a2 /package/kernel/modules/block.mk
parent6ca9b8b2b265177fdb9d5f1e4742b10bcb1f7dfc (diff)
downloadmaster-187ad058-f6c457dbde39d676a20f4caf34ae5293c5361574.tar.gz
master-187ad058-f6c457dbde39d676a20f4caf34ae5293c5361574.tar.bz2
master-187ad058-f6c457dbde39d676a20f4caf34ae5293c5361574.zip
[ubicom32] prevent some modules from being built on ubicom32 since they do not compile or link
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18595 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/modules/block.mk')
-rw-r--r--package/kernel/modules/block.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/modules/block.mk b/package/kernel/modules/block.mk
index 37c1045eea..cbdf2b3a0f 100644
--- a/package/kernel/modules/block.mk
+++ b/package/kernel/modules/block.mk
@@ -10,7 +10,7 @@ BLOCK_MENU:=Block Devices
define KernelPackage/ata-core
SUBMENU:=$(BLOCK_MENU)
TITLE:=Serial and Parallel ATA support
- DEPENDS:=@PCI_SUPPORT @LINUX_2_6 +kmod-scsi-core
+ DEPENDS:=@PCI_SUPPORT @LINUX_2_6 +kmod-scsi-core @!TARGET_ubicom32
KCONFIG:=CONFIG_ATA
FILES:=$(LINUX_DIR)/drivers/ata/libata.$(LINUX_KMOD_SUFFIX)
AUTOLOAD:=$(call AutoLoad,21,libata)